FF remembers wrong page in history (JavaScript)

RESOLVED INVALID

Status

()

Firefox
Bookmarks & History
RESOLVED INVALID
12 years ago
10 years ago

People

(Reporter: Oliver Block, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; de; rv:1.8.0.1) Gecko/20060124 Firefox/1.5.0.1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; de; rv:1.8.0.1) Gecko/20060124 Firefox/1.5.0.1

You load three (or other number) html documents, one after the other. You load document 1 and 3 using window.open() (JavaScript). Document 2 is loaded using window.location.replace(). After document 3 was loaded, you hit the back button. Now document 2 does appear but not document 1. 

Reproducible: Always

Steps to Reproduce:
1. Load the pages in a row into the browser using JavaScript. (Description follows.
2. To load page 1 and 3, as follows: mywindow = window.open(url,name);
3. load page 2 (after page 1) this way: mywindow.location.replace(url);
4. After loading the last page (page 3) into the browser, hit the back button.
Actual Results:  
page 2 appears.

Expected Results:  
page 1 should appear, because page 2 was loaded using location.replace()
(Reporter)

Comment 1

12 years ago
Error in reasoning. This is of course NO BUG!

SORRY FOR THE NOISE.

Updated

12 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → INVALID

Updated

10 years ago
Component: History → Bookmarks & History
QA Contact: history → bookmarks
You need to log in before you can comment on or make changes to this bug.