Editable trees: selecting text with mouse exits edit mode

RESOLVED DUPLICATE of bug 350332

Status

()

RESOLVED DUPLICATE of bug 350332
12 years ago
10 years ago

People

(Reporter: asqueella, Assigned: janv)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
STR:
1. Open attachment 235591 [details]
2. Double-click the first cell to edit
3. Click inside the textbox to get rid of initial selection
4. Select text in the textbox using mouse

Actual results:
When you finish selecting text (on mouseup) the textbox disappears

Expected results:
The text in the textbox is selected appropriately.

This happens because a select event gets handled here:
http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/toolkit/content/widgets/tree.xml&rev=1.37&mark=408#400
(Reporter)

Comment 1

12 years ago

*** This bug has been marked as a duplicate of 350332 ***
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE

Updated

10 years ago
Component: XP Toolkit/Widgets: Trees → XUL
QA Contact: xptoolkit.trees → xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.