problems with the image in the "tbird thinks this message might be a scam" / "blocking remote images" bar

RESOLVED FIXED in Thunderbird2.0

Status

Thunderbird
Mail Window Front End
RESOLVED FIXED
12 years ago
12 years ago

People

(Reporter: (not reading, please use seth@sspitzer.org instead), Assigned: Scott MacGregor)

Tracking

({fixed1.8.1})

Thunderbird2.0
x86
Mac OS X
fixed1.8.1

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(4 attachments)

problems with the image in the "tbird thinks this message might be a scam" bar

screen shot coming.

I'm using version 2 alpha 1 (20060816) on mac.  (hmm, when I do check for updates, none are found.)
> hmm, when I do check for updates, none are found.

still no updates, and I am running the build that I should be getting updates.

scott / paul:  do you know if there are any AUS issues with mac tbird branch nightlies?

Comment 3

12 years ago
(In reply to comment #2)
> > hmm, when I do check for updates, none are found.
> 
> still no updates, and I am running the build that I should be getting updates.
> 
> scott / paul:  do you know if there are any AUS issues with mac tbird branch
> nightlies?

According to http://users.ox.ac.uk/~clar0239/upwatch/latest/, I don't see any current issues with Tbird 1.8 nightly updates.

What's the full build ID of the build you're trying to update? Are you sure it's checking the nightly channel?
> According to http://users.ox.ac.uk/~clar0239/upwatch/latest/, I don't see any
> current issues with Tbird 1.8 nightly updates.

wow, that's a useful page.

> What's the full build ID of the build you're trying to update? Are you sure
> it's checking the nightly channel?

my user agent is Thunderbird 2.0a1 (Macintosh/20060816) and app.update.channel is nightly.

I'll try setting the appropriate app.update.log.* prefs to see if I can tell what's going on.
after setting the logging prefs, I see this in my console:

update url: https://aus2.mozilla.org/update/1/Thunderbird/2.0a1/2006081605/Darwin_ppc-gcc3/en-US/nightly/update.xml

checkForUpdates: sending request to https://aus2.mozilla.org/update/1/Thunderbird/2.0a1/2006081605/Darwin_ppc-gcc3/en-US/nightly/update.xml

onLoad: request completed downloading document

Updates available: 0

Going to https://aus2.mozilla.org/update/1/Thunderbird/2.0a1/2006081605/Darwin_ppc-gcc3/en-US/nightly/update.xml

gives me <updates></updates>

I'd expect there to be at least one <update> there, taking me to the latest nightly.

maybe 8/16 is "too long ago" for nightlies and the update.xml has been removed?

Comment 6

12 years ago
(In reply to comment #5)
> after setting the logging prefs, I see this in my console:
> 
> update url:
> https://aus2.mozilla.org/update/1/Thunderbird/2.0a1/2006081605/Darwin_ppc-gcc3/en-US/nightly/update.xml

Hrm... I think the bigger problem here is that those builds are UB (I think?), but the update URL is using a PPC only platform.

Note that:

https://aus2.mozilla.org/update/1/Thunderbird/2.0a1/2006081605/Darwin_Universal-gcc3/en-US/nightly/update.xml

gives the right update.

Do the current nightlies have this problem? It may be that we fixed updates, and older nightlies will not get updates because they're checking the wrong platform.
(Assignee)

Comment 7

12 years ago
going back to the original problem.

The image only seems to have problems on the branch. the trunk shows the phishing icon correctly. 
(Assignee)

Comment 8

12 years ago
It looks like the new firefox theme on the branch altered the dimensions of the icon we use for the phishing bar. And those changes haven't gone into the trunk yet (oops) which is why it still works on the trunk. 
Status: NEW → ASSIGNED
(Assignee)

Comment 9

12 years ago
Created attachment 236876 [details] [diff] [review]
(branch only) the fix

The toolkit icon we use for the phishing indicator is now 24px x 24 px on the branch only.
Attachment #236876 - Flags: superreview?(sspitzer)
Comment on attachment 236876 [details] [diff] [review]
(branch only) the fix

sr=sspitzer, acting as mailnews sr while bienvenu is away
Attachment #236876 - Flags: superreview?(sspitzer) → superreview+
(Assignee)

Updated

12 years ago
Keywords: fixed1.8.1
Target Milestone: --- → Thunderbird2.0
(Assignee)

Updated

12 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
scott, I've updated to version 2 alpha 1 (20060906) and I still see this bug.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 12

12 years ago
That's odd, I just updated to today's nightly as well on the branch and it's working now. But I do see an odd flicker before the icon loads in the phishing bar. Hmmm....
ah!  the "tbird thinks this message might be a scam" image is ok, but the image used for remote images ("to protect your privacy, Tbird has blocked remote images in this message") has the original problem.

Sorry for the confusion.

do you want a new bug, or should we re-use this bug?
Summary: problems with the image in the "tbird thinks this message might be a scam" bar → problems with the image in the "tbird thinks this message might be a scam" / "blocking remote images" bar
(Assignee)

Comment 14

12 years ago
we can re-use this one. It's probably the same problem.
(Assignee)

Comment 15

12 years ago
Created attachment 237137 [details] [diff] [review]
same fix for the remote image toolbar

I also searched through lxr to see where else pinstripe is using console-toolbar.png and didn't find any other spots.
(Assignee)

Comment 16

12 years ago
ok, this 2nd patch is now on the branch as well. Re-closing. Good catch Seth!
Status: REOPENED → RESOLVED
Last Resolved: 12 years ago12 years ago
Resolution: --- → FIXED

Comment 17

12 years ago
*** Bug 351115 has been marked as a duplicate of this bug. ***
I just updated to version 2 alpha 1 (20060908), and this is verified fix.  Thanks scott!
Status: RESOLVED → VERIFIED
Unfortunately, that wasn't a "branch-only" change, just a "branch-first" change, so now the trunk needs the same again.
Status: VERIFIED → REOPENED
Resolution: FIXED → ---
Created attachment 246248 [details] [diff] [review]
Both, for trunk

Never let it be said that I'll shy away from a trivial patch.
Attachment #246248 - Flags: review?(mscott)
(Assignee)

Comment 21

12 years ago
Comment on attachment 246248 [details] [diff] [review]
Both, for trunk

Ah thanks Phil.
Attachment #246248 - Flags: review?(mscott) → review+
Fixed on trunk (fortunately, without my "242px" typo).
Status: REOPENED → RESOLVED
Last Resolved: 12 years ago12 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.