"Open with other application" leads to a browse window that will not take keyboard input

RESOLVED WORKSFORME

Status

()

Firefox
File Handling
RESOLVED WORKSFORME
12 years ago
8 years ago

People

(Reporter: Walter Neumann, Unassigned)

Tracking

2.0 Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.6) Gecko/20060808 Fedora/1.5.0.6-2.fc5 Firefox/1.5.0.6
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.6) Gecko/20060808 Fedora/1.5.0.6-2.fc5 Firefox/1.5.0.6

 Firefox asks what application to open pdf with but does not offer acroread, which is what I want(yy firefox intermittently forgets what to open pdf with since installing googlesync). Firefox offers a "browse for application" window with no option to enter "/usr/bin/acroread" by hand. Browsing to /usr/local/bin takes about a minute to populate the browse window.  I would much prefer to quickly enter the known location by hand.



Reproducible: Always

Steps to Reproduce:
1.Choose "other application" when asked what to open a file with
2.
3.

Actual Results:  
 The resulting browse window offers no text entry and is ridiculously slow when browsing to /usr/bin (or any other directory with many files)

Expected Results:  
A window that gives the option to enter the application manually if known 
(and that does not take so long to browse directories otherwise)

Comment 1

11 years ago
I am really finding this annoying too. This is one of the irritating things which shows us that Firefox is mainly focused on the MS Windows operating system. You may call Firefox a multiplatform browser but in the end it will be a Windows browser that also runs on Linux. This may sound silly, but I think the Mozilla foundation should really be aware of this and it may get worse when the Mozilla foundation will cooperate with Microsoft (or would there be another reason why MS is so interested in cooperating?).

Back to the bug report... The "Change Action" window is clearly focused on MS Windows and the OS's poor way of letting the user select a preferred application.
So how should it be implemented for Linux (and other Open operating systems) then? Well just enabling the user to fill in the command of the application is not enough, because there still is a "Browse..." button and that is a "Windows thing". Under Linux you do not want to select an application by browsing through your file system, because Linux desktop users are used to selecting an application from a well categorized application tree. So replace the "Browse..." button by something like a "Choose..." button that will show an application tree after it has been pressed.

Some references:
- A program that also uses an application tree for selecting an application: http://keytouch.sf.net/screenshots.php
- Freedesktop.org has defined the standards for application menus: http://freedesktop.org/wiki/Standards

Firefox is a very popular Open Source application and also very popular on the proprietary Windows OS. However I think that such a large Open Source project cannot be taken serious when it is not focusing on the Free and Open desktop too.

Regards,
Marvin Raaijmakers
Reporter, do you still see this problem with the latest Firefox 2? If not, can you please close this bug as WORKSFORME. Thanks!
Whiteboard: CLOSEME 07/14
Version: unspecified → 1.5.0.x Branch
(Reporter)

Comment 3

11 years ago
This is still a bug in 2.0.0.4. 

The "Choose Helper Application" window offers no text entry box to enter the location of the application. So you must mouse to it, which is a stupid waste of time in the best of cases, but if your application is in /usr/local/bin (as it probably is) it takes about a minute for Firefox to populate the window with the approx 3000 applications in that directory and then scrolling through them to find your application takes another minute.

I can type "/usr/bin/progname" in 3 seconds. I don't want to have to spend two minutes getting there with a mouse!  Even worse, Firefox freezes while it is populating the /usr/bin directory so you can't even cancel out to download the item and open it by hand (which would be much faster).

Updated

11 years ago
Whiteboard: CLOSEME 07/14
Version: 1.5.0.x Branch → 2.0 Branch

Comment 4

11 years ago
I would like to add a ME TOO to this. 

I am using Gentoo, Firefox 2.0.0.4 and fluxbox-1.0_rc3_p4949. I have exactly the same problem.  There seems to be something wrong with the way the directory listings are made. I can reproduce it by doing "File->Open File" as well from Firefox and browsing through the directories. Not all of them take a long time to show but many do.  'ls' is always instant on the system so it doesn't seem to be a filesystem problem.

Is there any information I can provide that would help?

Raphael

Comment 5

11 years ago
To be clear, I can hear the hard drive thrashing during the long waits for the directory listing to come up. 


Raphael
This bug was reported on Firefox 2.x or older, which is no longer supported and will not be receiving any more updates. I strongly suggest that you update to Firefox 3.6.3 or later, update your plugins (flash, adobe, etc.), and retest in a new profile. If you still see the issue with the updated Firefox, please post here. Otherwise, please close as RESOLVED > WORKSFORME
http://www.mozilla.com
http://support.mozilla.com/kb/Managing+profiles
http://support.mozilla.com/kb/Safe+mode
(Reporter)

Updated

8 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.