Flash of a different update window, then regular update window shows

RESOLVED FIXED in mozilla1.8.1

Status

()

RESOLVED FIXED
12 years ago
10 years ago

People

(Reporter: u88484, Unassigned)

Tracking

({fixed1.8.1})

1.8 Branch
mozilla1.8.1
x86
Windows XP
fixed1.8.1
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

12 years ago
While checking for updates, if an update is found there is a different update window that flashs for about a second on my pretty fast system...on slower machines a little more time, then the regular update window is shown. See attached screenshots. I think this started after the landing of the minor/major update patches.
(Reporter)

Comment 1

12 years ago
Created attachment 235773 [details]
first window
(Reporter)

Comment 2

12 years ago
Created attachment 235774 [details]
second regular window
Seth: is this one yours? Or maybe the nightly update.xml is being published wrong for the changes now?
investigating.  

I don't think the problem is with update.xml for the nightlies.
Assignee: nobody → sspitzer
thanks again for catching this, kurt.

I think the fix for this would be to move the call to "detailsDeck.selectedIndex = 1;" to after all the code (in onShowMoreDetails(), see http://lxr.mozilla.org/mozilla1.8/source/toolkit/mozapps/update/content/updates.js#742) that twiddles the various UI elements in that card of the deck, before switching to it.

but me first confirm that this is really what's going on (by adding a delay after the call to "detailsDeck.selectedIndex = 1;") and confirm that my idea would fix it.

(asking for blocking, as this is a regression from 1.5)

if you look at the diff of my checkin for bugs #329730 and bug #348389, I added all the code to twiddles the UI (for major and minor) *after* the existing call to "detailsDeck.selectedIndex = 1;",
Status: NEW → ASSIGNED
Flags: blocking-firefox2?
Keywords: regression
I am wondering why kurt's screen shots show a branded version of the software update wizard.  

I'm not seeing the branding on trunk or branch (that was a problem a while back, but it has been fixed.)
kurt, what's your build id?
(Reporter)

Comment 8

12 years ago
Screenshot were from trolly on mozillazine forums. I could never catch a screenshot because it was so quick. I'm using latest trunk though and not sure if its branded or not. Will have to try again tomorrow.
some additional info:

I think the ui bug represented by the screen shots correspond to onPageShow() for gUpdatesAvailablePage is slow, not if onShowMoreDetails() (as I mentioned earlier).

I'm not so sure this is a blocker anymore either.

Created attachment 235911 [details]
update windows with incompatible extensions

The second window points out incompatible extensions, the first one doesn't.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060828 Minefield/3.0a1 ID:2006082804 [cairo]
> update windows with incompatible extensions
> The second window points out incompatible extensions, the first one doesn't.

dao, thanks for the screen shots.  

a quick question: are those screen shots taken from your trunk build as the update wizard comes up?  (You see image #1, and then image #2?)

as I mentioned in comment #9, this screen shot (and the originally described problem) seem possible if onPageShow() takes a while to complete.

one reasonable way for that to happen is if the check for incompatible extensions took a while to complete (which happens in onPageShow() before the call to onShowMoreDetails();

see http://lxr.mozilla.org/mozilla1.8/source/toolkit/mozapps/update/content/updates.js#698

dao, do you happen to have lots of extensions?

I'm not going to mark this as blocking? / regression until I'm sure.
Flags: blocking-firefox2?
Keywords: regression
Whiteboard: [note to drivers: not sure if this is a regression yet]
(In reply to comment #11)
> a quick question: are those screen shots taken from your trunk build as the
> update wizard comes up?  (You see image #1, and then image #2?)

I see image 1, and image 2 like 1 second afterwards. I chose "Check for Updates..." manually, if that matters.

> dao, do you happen to have lots of extensions?

Yes, I do have 37 extensions + 7 themes installed.
(Reporter)

Comment 13

12 years ago
(In reply to comment #12)
> (In reply to comment #11)
> > a quick question: are those screen shots taken from your trunk build as the
> > update wizard comes up?  (You see image #1, and then image #2?)
> 
> I see image 1, and image 2 like 1 second afterwards. I chose "Check for
> Updates..." manually, if that matters.

same here

> 
> > dao, do you happen to have lots of extensions?
> 
> Yes, I do have 37 extensions + 7 themes installed.
> 

I only have 3...talkback and two of my own extensions
(Reporter)

Comment 14

12 years ago
(In reply to comment #8)
> Screenshot were from trolly on mozillazine forums. I could never catch a
> screenshot because it was so quick. I'm using latest trunk though and not sure
> if its branded or not. Will have to try again tomorrow.
> 

Yep not branded here on both of the windows
based on the original bug report, I claim by fix for bug #351821 fixes this exact issue.

dao / kurt, could you update and try again?  Note, to see the test you will need to first update to get a build with the fix, and then update again (the next day) in order to see the fix in action.

On the branch, you should see "Please wait..." (instead of this bug.)  On the trunk, you should see "Checking if this update will cause problems with your extensions and/or themes...".
Status: ASSIGNED → RESOLVED
Last Resolved: 12 years ago
Keywords: fixed1.8.1
Resolution: --- → FIXED
Whiteboard: [note to drivers: not sure if this is a regression yet]
Target Milestone: --- → Firefox 2
Version: Trunk → 2.0 Branch
(In reply to comment #15)
worked for me.
(Reporter)

Comment 17

12 years ago
Still there for me when updating Firefox trunk from 18th t19th nightly.  Seen it the other day also.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
kurt, could you get some screen shots (and indicate which build you were using?)
Status: REOPENED → ASSIGNED
> I think the fix for this would be to move the call to
> "detailsDeck.selectedIndex = 1;" to after all the code (in onShowMoreDetails()

this is now covered in bug #352400
kurt, when you get tomorrow's update (for the trunk), can you tell me if you see the new UI (with the throbber)

it should look something like https://bugzilla.mozilla.org/attachment.cgi?id=238550 (note, that is for the mac, but windows trunk should look similar.)

specificially, do you see the throbber and the "Checking if this update will cause problems with your extensions and/or themes..." text?
sorry for the bug spam, re-assigning bugs back to default owner if I'm not working actively on them.
Assignee: sspitzer → nobody
Status: ASSIGNED → NEW
(Reporter)

Comment 22

11 years ago
Well I haven't seen this in a long, long time so I'm resolving this as fixed.
Status: NEW → RESOLVED
Last Resolved: 12 years ago11 years ago
Resolution: --- → WORKSFORME

Updated

11 years ago
Depends on: 351821
Resolution: WORKSFORME → FIXED
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.