Crashes [@ nsFormFillController::SetPopupOpen]

RESOLVED FIXED

Status

()

Toolkit
Autocomplete
--
critical
RESOLVED FIXED
12 years ago
7 years ago

People

(Reporter: smaug, Assigned: smaug)

Tracking

({fixed1.8.1, topcrash})

Trunk
x86
Linux
fixed1.8.1, topcrash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

Attachments

(1 attachment)

(Assignee)

Description

12 years ago
According to TB there are quite a few crashes @ http://bonsai.mozilla.org/cvsblame.cgi?file=/mozilla/toolkit/components/satchel/src/nsFormFillController.cpp&mark=253&rev=MOZILLA_1_8_BRANCH#253
If the document is being destroyed, docshell may be null.
(Assignee)

Comment 1

12 years ago
Created attachment 235782 [details] [diff] [review]
Adding null checks

This should be ok.
Attachment #235782 - Flags: review?
(Assignee)

Updated

12 years ago
Attachment #235782 - Flags: review? → review?(michael.wu)
(Assignee)

Updated

12 years ago
Component: Form Manager → Autocomplete
Flags: review?(michael.wu)
Product: Firefox → Toolkit
(Assignee)

Comment 2

12 years ago
Comment on attachment 235782 [details] [diff] [review]
Adding null checks

ugh, bugzilla doesn't like product/component changes
Attachment #235782 - Flags: first-review?(michael.wu)
(Assignee)

Comment 3

12 years ago
This should go to 1.8.1 too.

Comment 4

12 years ago
Comment on attachment 235782 [details] [diff] [review]
Adding null checks

So apparently we can have this function called as the docshell is getting destroyed. Smaug thinks it may be caused by a timer. At any rate, I wonder if the presentation shell can be null when the docshell isn't, and if we really want to spit out another warning on the console if docshell ends up null.
Attachment #235782 - Flags: first-review?(michael.wu) → first-review?(jst)
(Assignee)

Comment 5

12 years ago
nsDocShell::GetPresShell may return null presshell.
(It is after all *Get*PresShell)
Comment on attachment 235782 [details] [diff] [review]
Adding null checks

r=jst
Attachment #235782 - Flags: first-review?(jst) → first-review+
(Assignee)

Comment 7

12 years ago
Comment on attachment 235782 [details] [diff] [review]
Adding null checks

Checked in to trunk.
Since the same crash may happen un 1.8.1. (but not in 1.8.0) asking for approval.
Attachment #235782 - Flags: approval1.8.1?
(Assignee)

Updated

12 years ago
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED

Updated

12 years ago
Whiteboard: [baking until 8/30]
Comment on attachment 235782 [details] [diff] [review]
Adding null checks

a=beltzner on behalf of 181drivers
Attachment #235782 - Flags: approval1.8.1? → approval1.8.1+
(Assignee)

Updated

12 years ago
Keywords: fixed1.8.1
Whiteboard: [baking until 8/30]
Severity: normal → critical
Keywords: topcrash
Crash Signature: [@ nsFormFillController::SetPopupOpen]
You need to log in before you can comment on or make changes to this bug.