[mac] Java apps crash browser abruptly.

RESOLVED DUPLICATE of bug 350664

Status

Core Graveyard
Java-Implemented Plugins
--
critical
RESOLVED DUPLICATE of bug 350664
12 years ago
6 years ago

People

(Reporter: Simon Howes, Assigned: Igor Kushnirskiy)

Tracking

({crash, regression})

Trunk
PowerPC
Mac OS X
crash, regression

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(7 attachments)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.9a1) Gecko/20060828 Minefield/3.0a1
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.9a1) Gecko/20060828 Minefield/3.0a1

Navigate to any web page that contains a JAVA app, browser freezes and then quits.

Reproducible: Always

Steps to Reproduce:
Navigate to any web page containing a JAVA app.

Actual Results:  
Browser quits.
(Reporter)

Updated

12 years ago
Summary: JAVA apps crash abruptly browser. → JAVA apps crash browser abruptly.
(Reporter)

Comment 1

12 years ago
Created attachment 235810 [details]
Crash log
Summary: JAVA apps crash browser abruptly. → Java apps crash browser abruptly.

Comment 2

12 years ago
Created attachment 235818 [details]
Java Crash log

This crash happened when *leaving* the page in the url field
steps:
1/ access page
2/ do test
3/ use back button twice to return here
--> crash

Comment 3

12 years ago
Created attachment 235819 [details]
Apple Crash log with Camino trunk build

Goes with the java crash log I just attached.

Java Console log reports this
MRJ Plugin for Mac OS X v1.0.1
[starting up Java Applet Security @ Tue Aug 29 09:10:21 JST 2006]
Tue Aug 29 09:10:24 JST 2006 JEP creating applet SpeedTester1 (http://speedtest2.adslguide.org.uk/)
ADSLguide.org.uk Broadband Speed Tester
Tue Aug 29 09:12:40 JST 2006 JEP creating applet SpeedTester1 (http://speedtest2.adslguide.org.uk/)
ADSLguide.org.uk Broadband Speed Tester
(Reporter)

Comment 4

12 years ago
Created attachment 235827 [details]
JAVA crash log.

Attached my JAVA crash log also.
I'm not able to reproduce any crashes with this site, or any problems
at all.  I tested with today's Firefox and Camino trunk nightlies
(2006-08-28-06-trunk for Firefox, 2006-08-28-01 for Camino).  I tested
on Mac OS X 10.4.7 (using Java 5.0, as you guys did) and on Mac OS X
10.3.9.

Neither of you has said _which_ nightlies you tested.  Please try
again with the ones I tested, if you haven't done so already.  Also
try testing with fresh profiles.

Comment 6

12 years ago
(In reply to comment #5)
> I'm not able to reproduce any crashes with this site, or any problems
> at all.  I tested with today's Firefox and Camino trunk nightlies
> (2006-08-28-06-trunk for Firefox, 2006-08-28-01 for Camino).  I tested
> on Mac OS X 10.4.7 (using Java 5.0, as you guys did) and on Mac OS X
> 10.3.9.
> 
> Neither of you has said _which_ nightlies you tested.  Please try
> again with the ones I tested, if you haven't done so already.  Also
> try testing with fresh profiles.

I always use the latest Camino trunk builds.
Anyway, with the latest Camino trunk build from Tinderbox
http://ftp.mozilla.org/pub/mozilla.org/camino/tinderbox-builds/maya-trunk/

--> about:plugins
--> Test your JVM link which goes to the java.com test applet
--> immediately crashed

Comment 7

12 years ago
Created attachment 235844 [details]
Java crah log for comment #6
(Reporter)

Comment 8

12 years ago
Using my own builds and also tinderbox (xserve03-trunk) crash.

I can also recreate the crash in comment 6.
(Reporter)

Comment 9

12 years ago
Created attachment 235888 [details]
Java crash log, comment 8
(Reporter)

Comment 10

12 years ago
Regression has started since 21st Aug 2006.  All previous builds work fine.
Keywords: crash, regression
Summary: Java apps crash browser abruptly. → [mac] Java apps crash browser abruptly.

Comment 11

12 years ago
Here is another site that crashes systematically:
http://www.abendblatt.de/

with Camino
Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en; rv:1.9a1) Gecko/20060829 Camino/1.2+
with Firefox
Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.9a1) Gecko/20060828 Minefield/3.0a1 ID:2006082806

From Console log
2006-08-29 21:14:49.234 Camino[490] JEP creating applet bandwidth (http://62.26.121.2/dat/bgf/)
MRJ Plugin JEP: JavaScript-to-Java LiveConnect failed -- no security manager!
MRJ Plugin JEP: JavaScript-to-Java LiveConnect failed -- no security manager!
> MRJ Plugin JEP: JavaScript-to-Java LiveConnect failed -- no security manager!

This isn't a crash.

The nsIScriptSecurityManager interface was changed recently
(2006-08-21) on the trunk, which broke JavaScript-to-Java LiveConnect.
I've got this worked around in my current version of the Java
Embedding Plugin, which I should be able to release in the next month
or so as JEP 0.9.5+h.

For more information see bug 348559 and bug 293973.

Comment 13

12 years ago
(In reply to comment #12)
> > MRJ Plugin JEP: JavaScript-to-Java LiveConnect failed -- no security manager!
> 
> This isn't a crash.

But the browser crashed allright
I just triggered it again on the url in comment 11

Console.log
### MRJPlugin:  getPluginBundle() here. ###
### MRJPlugin:  CFBundleGetBundleWithIdentifier() succeeded. ###
### MRJPlugin:  CFURLGetFSRef() succeeded. ###
2006-08-30 12:08:55.091 Camino[9846] JEP creating applet bandwidth (http://62.26.121.2/dat/bgf/)
MRJ Plugin JEP: JavaScript-to-Java LiveConnect failed -- no security manager!
MRJ Plugin JEP: JavaScript-to-Java LiveConnect failed -- no security manager!
Aug 30 12:08:56 pikun /Applications/Camino.app/Contents/MacOS/Camino: An unexpected Java error has been detected by HotSpot Virtual Machine.

followed by all the usual lines about java applets crashing

In Java Console.log:
MRJ Plugin for Mac OS X v1.0.1
[starting up Java Applet Security @ Wed Aug 30 12:08:54 JST 2006]
Wed Aug 30 12:08:55 JST 2006 JEP creating applet bandwidth (http://62.26.121.2/dat/bgf/)
java.lang.NullPointerException
	at bandwidth.init(bandwidth.java:58)
	at sun.applet.AppletPanel.run(AppletPanel.java:378)
	at jep.AppletHolderPanel.run(AppletHolderPanel.java:148)
	at java.lang.Thread.run(Thread.java:613)

I'll attach the crash log, which is not much different from all the previous ones, as far as I can see.

Comment 14

12 years ago
Created attachment 236006 [details]
java crash log for comment 13
>> This isn't a crash.
>
>But the browser crashed allright
>I just triggered it again on the url in comment 11

You're right, in a way.  But so was I.

> unexpected Java error has been detected by HotSpot Virtual Machine.

The "unexpected Java error" that made the JVM (and the browser) crash
wasn't itself a crash (though it ususally is).

I'm still not sure that all the problems that have been reported here
are the problem I described in comment #12.  But if so, this bug
should be resolved by the next release of the JEP (coming in a month
or so).

*** This bug has been marked as a duplicate of 350664 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
Component: Java-Implemented Plugins → Java-Implemented Plugins
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.