If you have an updates.xml with multiple major releases, and you've said "never" to the "biggest" major, you will not be prompted for the next "biggest" update.

RESOLVED DUPLICATE of bug 586194

Status

()

Toolkit
Application Update
RESOLVED DUPLICATE of bug 586194
12 years ago
8 years ago

People

(Reporter: (not reading, please use seth@sspitzer.org instead), Unassigned)

Tracking

1.8 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

If you have an updates.xml with mutliple major releases, and you've said "never" to the "biggest" major, you will not be prompted for the next "biggest" update.

I don't know if we ever plan on pushing multiple major updates, but the updates.xml format doesn't prevent us from doing so, so it's possible.

I've just tested this, and I did not get prompted for the 2nd biggest "major" release (where I had said "never" to the biggest.)

this issue is related to how selectUpdate() only returns one update, see http://lxr.mozilla.org/mozilla1.8/source/toolkit/mozapps/update/src/nsUpdateService.js.in#1285 and how the "never" pref is checked after that.

I don't feel this blocks ff2.
Summary: If you have an updates.xml with mutliple major releases, and you've said "never" to the "biggest" major, you will not be prompted for the next "biggest" update. → If you have an updates.xml with multiple major releases, and you've said "never" to the "biggest" major, you will not be prompted for the next "biggest" update.
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
I am very certain this has been fixed by bug 586194... resolving -> duplicate
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 586194
You need to log in before you can comment on or make changes to this bug.