Closed Bug 350702 Opened 18 years ago Closed 18 years ago

for..in in finally can cause "Assertion failure: !JS_IsExceptionPending(cx)"

Categories

(Core :: JavaScript Engine, defect)

PowerPC
macOS
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 350837

People

(Reporter: jruderman, Unassigned)

References

Details

(Keywords: crash, testcase)

javascript:try { throw 0; } finally {for (var i in []) ; }

Assertion failure: !JS_IsExceptionPending(cx), at jsiter.c:568

Wasn't the fix for bug 346029 supposed to prevent this kind of problem?
As Jesse asked over there, is this a dup of bug 350837 ?

/be
Depends on: 350837
This bug and the bug 350837 as the issue. Somehow I missed this bug when I filed 350837 and put the fix there :(

*** This bug has been marked as a duplicate of 350837 ***
Status: NEW → RESOLVED
Closed: 18 years ago
Resolution: --- → DUPLICATE
A testcase for this bug was already added in the original bug (bug 350837).
Flags: in-testsuite-
You need to log in before you can comment on or make changes to this bug.