If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Missing left (and right) margin for address and search bars

RESOLVED FIXED in Firefox 2

Status

()

Firefox
Toolbars and Customization
P1
normal
RESOLVED FIXED
11 years ago
11 years ago

People

(Reporter: Simon Bünzli, Assigned: Gavin)

Tracking

({fixed1.8.1})

2.0 Branch
Firefox 2
x86
Windows XP
fixed1.8.1
Points:
---
Dependency tree / graph
Bug Flags:
blocking-firefox2 +

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [Fx2 theme change])

Attachments

(3 attachments)

(Reporter)

Description

11 years ago
If you move either of them to the very left of a toolbar, they look quite squeezed - and when moved to the right of the menu bar, there's no margin between the right-most menu and the bar at all.

Not sure how this will be handled when the Go button can be removed separately, but when done through CSS, there's currently no margin to the right either.
(Reporter)

Comment 1

11 years ago
Created attachment 236095 [details]
screenshot

BTW: Spacing between the individual elements still looks slightly flaky in general.

Updated

11 years ago
Depends on: 347964
(Reporter)

Comment 2

11 years ago
After the Winstripe rollup, in the default layout the Home button's bevel now touches the address bar which looks kind of weird (especially since there's margin above and below the address bar). Requesting blocking.
Flags: blocking-firefox2?
Yeah, now that we're using system bevels, this is strange. I'll find someone to take this. Marking theme change, even though I don't know if it is, but just to get it to show up in the right queries.
Flags: blocking-firefox2? → blocking-firefox2+
Whiteboard: [Fx2 theme change]
Target Milestone: --- → Firefox 2

Comment 4

11 years ago
*** Bug 347720 has been marked as a duplicate of this bug. ***
Assignee: nobody → gavin.sharp
Status: NEW → ASSIGNED
Priority: -- → P1
Created attachment 238005 [details] [diff] [review]
patch

Adds a left margin to the urlbar and search bar.
Attachment #238005 - Flags: review?(mconnor)
Created attachment 238006 [details]
before&after screenshot
Whiteboard: [Fx2 theme change] → [patch-r?][Fx2 theme change]
Comment on attachment 238005 [details] [diff] [review]
patch

r+a=me, let's get this in ASAP.
Attachment #238005 - Flags: review?(mconnor)
Attachment #238005 - Flags: review+
Attachment #238005 - Flags: approval1.8.1+
mozilla/browser/themes/winstripe/browser/browser.css 	1.17.2.57
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago
Keywords: fixed1.8.1
Resolution: --- → FIXED
Whiteboard: [patch-r?][Fx2 theme change] → [Fx2 theme change]
You need to log in before you can comment on or make changes to this bug.