Closed Bug 350804 Opened 14 years ago Closed 13 years ago

Unable to get an update after failing the full update - Alpha1->Beta2

Categories

(Toolkit :: Application Update, defect)

1.8 Branch
defect
Not set

Tracking

()

RESOLVED INVALID

People

(Reporter: marcia, Unassigned)

Details

Attachments

(1 file)

Testing on a PPC Mac running 10.4.7

STR:

1. Download the Alpha 1 Universal Binary and Check for Updates.
2. Download the Update and hit later.
3. Hand edit the update.status file to failed
4. Relaunch the build.
5. The update dialog comes up again and asks you to download the update. Download the update again.

The update dialog hangs and you are unable to download the update. Tried this several times and the same thing happened.
I also see this bug testing on an Intel Mac starting from the UB trying to get to the Beta2 UB.
I see this on Windows XP too, trying to jump from Alpha1->Beta2. Nominating - we should look into this further since it is likely to come up in the future when we publish full jumps. If a full fails, we should be able to go out and get another full without hanging.
Flags: blocking-firefox2?
OS: Mac OS X 10.3 → All
Hardware: Macintosh → All
Summary: [mac] Unable to get an update after failing the full update - Alpha1->Beta2 → Unable to get an update after failing the full update - Alpha1->Beta2
Intelmac. If you go from 2.0b1 to 2.0b2, and you fail the failover-to-full update by editing the update.status file to "failed", when you relaunch it will complain that the update failed to download and give you the option to download a full update, again. You click OK, but it hangs and stays like that until you close that window. If you then Check Updates again, it will bring up a dialog saying it is downloading a full update, but it also hangs. You have to close that dialog window.

If you restart the applicatio after that you will see the Check for Updates menu item in Help, and if you select it, Firefox will check and find a partial.
On the Windows XP alpha, the next time I launch the build after force quitting and go to check for updates, I get the Software update dialog but it is still frozen - it shows that the download is paused but nothing is moving.
Marcia will attach an update log...   
Since the error occurs in the client, there probably isn't an update log.
I also noticed that my update.status file says "null", and there is no lastupdate.log file.
This is the sort of problem that bug 302348 has fixed in nightlies, but that isn't in the client code until 2.0Does 1.5.0.x normally pass this sort of test ?
I can reproduce the problem with 2.0a1 but not 2.0a2, using WinXP, the betatest channel and the STR in comment #0.
Unless I'm reading things wrong, this is a Firefox2 Alpha 1 bug only, somehow fixed by a different bug, and thus should be resolved INVALID and/or WFM and not blocking. Let me know (by renominating) if I'm getting that wrong ...
Flags: blocking-firefox2? → blocking-firefox2-
Resolving this as invalid. I saw the same issue with the Alpha1 Build when were were testing the jump from Alpha1->RC1. The same issue did not occur with Alpha2.
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → INVALID
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.