Filtered message weirdness with IMAP delete model.

VERIFIED FIXED in mozilla0.8

Status

MailNews Core
Backend
P3
normal
VERIFIED FIXED
18 years ago
10 years ago

People

(Reporter: laurel, Assigned: Bienvenu)

Tracking

Trunk
mozilla0.8

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta1+])

(Reporter)

Description

18 years ago
Using 2000-04-06 m15 commercial builds

When IMAP delete model is set ("Mark as Deleted") and message filters fire to
move messages to another folder, the filtered message will appear and disappear
when switching between the destination folder and INBOX.

The message shows in the destination folder, then when you switch to INBOX the
message will briefly appear then disappear. If you switch back to the
destination folder you will see two entries for the filtered message -- you will
see one new message and one with an X for "mark as deleted as if the message was
being re-filtered/moved back and forth when you selected the INBOX for the
second time.

1.  Migrate an IMAP profile with the following:
       a.  IMAP delete model pref set -- to Mark as Delete
       b.  filter set to move incoming message to another folder on the IMAP
server.
2.  Send yourself a message which will cause the filter to fire.
3.  In seamonkey, go to mail and login to IMAP inbox.
    Note the message which matched filter criteria is not in the inbox. (I
believe it should be in the inbox, but marked with an X for deletion.)
4.  Open the destination folder for the filtered message.  The message is
present (and has not been marked for deletion). 
5.  Open the IMAP inbox again.
    Notice the filtered message (with an X for marked as deleted) flashes in the
thread pane then disappears.
6.  Open the filter destination folder again.
    Notice there are two entries for the filtered message.  One is not marked
for deletion, one is marked for deletion.

Actual result:  Filtered message appears and quickly disappears when selecting
Inbox if switching between inbox and filter destination folder.  Filtered
message appears in duplicate in destination folder as if refiltered when
switching between the folders.

Expected result:  Inbox should show one entry with X/marked as deleted. This Xed
entry should not disappear from the inbox until that folder is compacted. 
Destination folder should show one unmarked entry -- the "real" filtered
message.  This state should not change when switching between destination folder
and INBOX.
(Reporter)

Updated

18 years ago
QA Contact: lchiang → laurel
(Reporter)

Comment 1

18 years ago
To clarify:  this filtering behavior happens in sessions after migration, this
is not a bug restricted to the immediate session after migration.
(Assignee)

Comment 2

18 years ago
accepting
Status: NEW → ASSIGNED

Comment 3

18 years ago
Target M17.
Target Milestone: --- → M17

Comment 4

18 years ago
moving to future.
Target Milestone: M17 → Future
(Assignee)

Comment 5

18 years ago
adding mail3 keyword
Keywords: mail3
(Assignee)

Comment 6

18 years ago
changing priorities
Priority: P3 → P2

Comment 7

18 years ago
markng nsbeta1+ and moving to mozilla0.8
Keywords: nsbeta1
Priority: P2 → P3
Whiteboard: [nsbeta1+]
Target Milestone: Future → mozilla0.8
(Assignee)

Comment 8

18 years ago
I'm not seeing this. Maybe fixing the other imap delete model filter bug fixed
this. Could you try it with tomorrow's trunk build? thanks!
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
(Reporter)

Comment 9

18 years ago
This case IMAP move to folder on same IMAP server seems to be working okay with
jan12 trunk builds. Other scenarios having problems will be reported separately.

OK  2001-01-12-04 commercial trunk  win98
OK  2001-01-12-08 commercial trunk linux rh6.0
OK  2001-01-12-08 commercial trunk mac OS 9.0
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.