Gmail compose window's context menu lacks editor-related options (copy, paste, cut)

RESOLVED WORKSFORME

Status

SeaMonkey
General
--
major
RESOLVED WORKSFORME
12 years ago
10 years ago

People

(Reporter: Hermann Schwab, Unassigned)

Tracking

1.8 Branch

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8.1b2) Gecko/20060830 SeaMonkey/1.1b
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8.1b2) Gecko/20060830 SeaMonkey/1.1b

seen on 
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8.0.7) Gecko/20060829 Firefox/1.5.0.7
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8.1b2) Gecko/20060830 SeaMonkey/1.1b



Reproducible: Always

Steps to Reproduce:

1. open gmail in some other tab
2. open compose window
3. mark a word of text over here and copy it using right-click
4. go to gmail compose window
5. right-click into To: textarea: context menu is showing 'Paste' entry
6. right-click into Subject: textarea: context menu is showing 'Paste' entry
7. right-click into mail body textarea: no 'Paste' entry seen


Actual Results:  
In the mail message body you only can use the Ctrl+V to paste.



Expected Results:  
working like Opera 9, same behaviour in To:, Subject: and message body, on right-click open context menu including 'Paste' entry.

Didn't matter if "Plain Text" or "Rich Formating" option was enabled.

As I don't like to use key's when I'm working with a mouse that bug seems to be a major inconvenience.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1b2) Gecko/20060831 BonEcho/2.0b2
Works for me in Firefox, both in trunk and in branch builds, in rich text and in plain text. Per Bug 312930 I think.
(Reporter)

Comment 2

12 years ago
wfm Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8.1b2) Gecko/20060829 BonEcho/2.0b2

So Bug 312930 Comment #51 From Martijn Wargers  2006-06-23 15:37 PDT

did fix this for Firefox 1.8.1 branch only, not for Firefox 1.5.0.7, nor Seamonkey.

Comment 3

12 years ago
I think this could be done by just porting the browser.js Martijn made in bug 312930 to SeaMonkey's browser.js.
Assignee: nobody → general
Component: Editor → General
OS: Windows 98 → All
Product: Core → Mozilla Application Suite
QA Contact: general
Hardware: PC → All
Summary: gmail compose window, mail body: can't paste using mouse, must use Ctrl+V → Gmail compose window's context menu lacks editor-related options (copy, paste, cut)

Comment 4

12 years ago
The browser.js changes, rather.
(Reporter)

Comment 5

10 years ago
WFM
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8.1.11) Gecko/20071128 SeaMonkey/1.1.7

tested using gmails old interface: https://mail.google.com/mail/?ui=1
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.