Closed Bug 350864 Opened 14 years ago Closed 14 years ago

Add ability to check news servers for new messages at startup

Categories

(MailNews Core :: Backend, defect)

x86
Windows XP
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: Bienvenu, Assigned: Bienvenu)

References

Details

(Keywords: fixed1.8.1)

Attachments

(1 file)

With the new folder views, we can't rely on checking news servers for new messages by simply expanding the news server in the folder pane. So we just need to turn on the ability to check news servers for new messages at startup. Patch upcoming.
Attached patch proposed fixSplinter Review
expose the pref UI for news servers and enable it in the backend.
Attachment #236241 - Flags: superreview?(mscott)
Attachment #236241 - Flags: approval-l10n+
was that a slip of the mouse? this shouldn't have any l10n impact :-)
Comment on attachment 236241 [details] [diff] [review]
proposed fix

yes it was :)
Attachment #236241 - Flags: superreview?(mscott)
Attachment #236241 - Flags: superreview+
Attachment #236241 - Flags: approval-l10n+
fixed on trunk and 2.0 branch
Status: NEW → RESOLVED
Closed: 14 years ago
Keywords: fixed1.8.1
Resolution: --- → FIXED
So does this make PerformExpandForAllOpenServers redundant?
Neil, it does seem like that shouldn't be needed.

I don't ever seem to have my news servers expanded on startup, even if I expanded them in a previous session - is that just me?
Apparently the "newsgroups not being expanded on startup" thing is controllable by a pref., news.persist_server_open_state_in_folderpane.

See bug 123029 (and the bugs mentioned in it) for more details. Is there really any reason to have this pref. now? It seems like we should just respect the last state of the folder...
So given comment #6, should we use a) bug 123029 b) a related bug c) a new bug for each of the following changes:
1) Get rid of PerformExpandForAllOpenServers
2) Get rid of GetPersistElided (or make it return true)
Let's use bug 123029 - the important thing is that we don't try to update the news groups because we expand the server, but rather because the user chose that setting in the server settings. We don't want double fetching of news group counts.
(In reply to comment #9)
> Let's use bug 123029 - the important thing is that we don't try to update the
> news groups because we expand the server, but rather because the user chose
> that setting in the server settings. We don't want double fetching of news
> group counts.

In my initial test of this (TB 3a1-0907), I find that expanding the server (in the regular folder tree-view) does, in fact, update the newsgroups.  This is true whether the newsserver is set to check at startup or not.  Is this as expected?  If not, is there already a bug about suppressing this?
yes, expanding the news server has always updated the news counts, and is the only way for the user to immediately force the updates of all subscribed newsgroup counts on a server, other than waiting for the check for new messages interval.
> In my initial test of this (TB 3a1-0907), I find that expanding the server (in
> the regular folder tree-view) does, in fact, update the newsgroups.

Actually, the usual behaviour is:
- on twisty click, expand and check news server
- on right arrow key hit, expand without checking news server
See bug 122006.

> This is true whether the newsserver is set to check at startup or not.

The startup pref just defines the behaviour for starting up with an expanded news server.
(In reply to comment #11)
> yes, expanding the news server has always updated the news counts, and is the
> only way for the user to immediately force the updates of all subscribed
> newsgroup counts on a server, other than waiting for the check for new
> messages interval.

OK; comment 9 can be read as saying "should not update newsgroups on server expansion" so I was looking for clarification.  btw, you can Get New Messages for a server or a newsgroup (F5/Ctrl+T/Get New toolbutton).
*** Bug 93809 has been marked as a duplicate of this bug. ***
*** Bug 320110 has been marked as a duplicate of this bug. ***
I'm sorry, I should have said "expanding news server on startup, automatically, should not fetch counts" or something like that...
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.