DM cannot handle downloads > 2GB

RESOLVED DUPLICATE of bug 184452

Status

()

Toolkit
Downloads API
RESOLVED DUPLICATE of bug 184452
12 years ago
10 years ago

People

(Reporter: Zbynek Novotny, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.6) Gecko/20060728 Firefox/1.5.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.6) Gecko/20060728 Firefox/1.5.0.6

Sorry if this has been reported, but the only bug mentioning 2GB limit was referring to a badly displayed size.

The problem I have encountered, however, causes downloads larger than 2^31 - 1 to be stopped and marked as complete. I tried to download Windows Vista ISO image twice today from the official site (which had already been closed earlier today, unfortunately), but in both cases the download stopped after 2 147 483 647 bytes were received, and the popup window showed up saying that the download was completed.

Reproducible: Always

Steps to Reproduce:
1. Try to download anything larger than 2^31 bytes and see if you get this behavior.


Actual Results:  
The file was marked as downloaded after the "limit" has been reached.

Expected Results:  
Successful completion of the download when _all_ the data were received.

*** This bug has been marked as a duplicate of 184452 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
no, not a dup of that bug

This is actually supposed to work, at least since bug 340956 was fixed. You used FF 1.5.0.6 for that?
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
(Reporter)

Comment 3

12 years ago
Yes, I checked the version of my copy of the browser just before I decided to file this bugreport.
hrm... are you downloading to a FAT32 or NTFS filesystem?
(Reporter)

Comment 5

12 years ago
The latter.

*** This bug has been marked as a duplicate of 184452 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago12 years ago
Resolution: --- → DUPLICATE
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.