Closed Bug 350938 Opened 13 years ago Closed 11 years ago

Updater does not resume update process correctly when process is killed while applying an update

Categories

(Toolkit :: Application Update, defect)

1.8 Branch
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 375619
mozilla1.8.1

People

(Reporter: jbecerra, Unassigned)

Details

Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1b1) Gecko/20060710
Firefox/2.0b1

While running Litmus test case 2445 I found that if you force quit the updater during the update process, the application did not restart.

To reproduce:
1. Download and install 2.0b1 and check for updates
2. Download the update but choose to install Later
3. Quit Firefox and relaunch
4. While it relaunches you will see a progress bar dialog saying an update is being applied, before it finishes kill the updater process (using activity monitor)
5. Relaunch Firefox

Expected: Firefox launches and updater tries to apply the update again.

Actual: Firefox will not launch.

I'm not sure the test case in Litmus is appropriate.
Summary: updater does not resume update process when you force quit it → Updater does not resume update process correctly when process is killed while applying an update
Product: Firefox → Toolkit
OS: Mac OS X → All
Hardware: x86 → All
I'm duping this over to a newer bug since it has a tad more info
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 375619
You need to log in before you can comment on or make changes to this bug.