adding smtp server fails if you've added and removed a lot in the profile's lifetime

VERIFIED FIXED

Status

VERIFIED FIXED
12 years ago
10 years ago

People

(Reporter: Bienvenu, Assigned: Bienvenu)

Tracking

({verified1.8.1.2})

Trunk
x86
Windows XP
verified1.8.1.2

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

12 years ago
I have a profile that has had a lot of smtp servers added and removed in its lifetime. Currently, I have the following smtp servers defined: "smtp1, smtp25, smtp3". If I try to add a new server, it adds successfully, but when I shutdown and restart, the new server is gone. The problem is that the code parses the server list tries to remove dupes, and when it sees smtp2 (the recently added one), it thinks it's a dup of smtp25. Fix upcoming.
(Assignee)

Comment 1

12 years ago
Created attachment 236356 [details] [diff] [review]
proposed fix
Attachment #236356 - Flags: superreview?(mscott)

Comment 2

12 years ago
Comment on attachment 236356 [details] [diff] [review]
proposed fix

good catch!
Attachment #236356 - Flags: superreview?(mscott) → superreview+
(Assignee)

Comment 3

12 years ago
fixed on trunk and branch
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Keywords: fixed1.8.1.2
Resolution: --- → FIXED
Verified for 1.8.1.2 with Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.8.1.2pre) Gecko/20070124 Thunderbird/2.0b2pre Mnenhy/0.7.4.10002 ID:2007012504
Status: RESOLVED → VERIFIED
Keywords: fixed1.8.1.2 → verified1.8.1.2

Updated

12 years ago
Duplicate of this bug: 348707
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.