Overflow on top right icons when the bookmark toolbar is moved in line with the menu

RESOLVED WORKSFORME

Status

()

Firefox
General
RESOLVED WORKSFORME
12 years ago
9 years ago

People

(Reporter: Darren, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: closeme 2009-04-15)

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1b2) Gecko/20060821 Firefox/2.0b2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1b2) Gecko/20060821 Firefox/2.0b2

This has been a problem before, but on both of the FF2 betas the problem has returned.

When the bookmark toolbar is moved into the whitespace next to the menus, and there is more than one icon to the right of it (not including the loading icon), there is overflow to the right of the screen and the buttons disappear off the edge of the screen.

Reproducible: Always

Steps to Reproduce:
1. Move bookmark toolbar to the top of the screen.
2. Make sure there are two or more icons to the right of it.

Actual Results:  
Icons to the right of the bookmark toolbar disappear off the screen

Expected Results:  
Bookmark toolbar should shrink to accommodate new icons.
Do you mean this: http://img226.imageshack.us/img226/2725/naamloosbu2.png ?
As you can see I have no problem with it. Tested latest BonEcho nightly on Windows XP.
(Reporter)

Comment 2

12 years ago
I updated my ff a few hours ago, so I think it's the latest build. In the screenshot, you are missing the loading circle from that line (the activity indicator). Did you remove it? Does yours still work when you try to add another icon?
Yeah, this makes no difference. Have you also tried it in Firefox's safe-mode?
http://kb.mozillazine.org/Safe_Mode_(Firefox)
(Reporter)

Comment 4

12 years ago
Created attachment 236413 [details]
screenshot of overflow bug

Running in safe-mode. Note: clicking out of the customize window doesn't make a difference

Comment 5

9 years ago
still see this problem?
if not, please close with resolution set to WORKSFORME.
if you do, please comment
Whiteboard: closeme 2009-04-15
(Reporter)

Comment 6

9 years ago
Thanks for the reminder. Appears fixed in releases for the last couple of months at least. This works for me now.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.