Firefox re-posts data when File>SaveAs is run.

RESOLVED DUPLICATE of bug 115174

Status

()

Firefox
General
--
critical
RESOLVED DUPLICATE of bug 115174
12 years ago
11 years ago

People

(Reporter: harry den dekker, Unassigned)

Tracking

({testcase})

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.6) Gecko/20060728 Firefox/1.5.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.6) Gecko/20060728 Firefox/1.5.0.6

Whereas F5 (Refresh) will prevent that data is not POSTed again, File>SaveAs appears to do a refresh without these checks.

The URL demonstrates how Firefox can be made to re-post data without the user being aware.  So, in a banking application, FF may cause a transaction to be performed twice, which may be costly to the user.

Instructions are on the demo page.  Follow the URL.

Reproducible: Always

Steps to Reproduce:
1. Go to http://test.foxobn.org/firefoxbugs/bug_file_save_as.php
2. Follow the instructions
3.

Actual Results:  
Data was posted more than once, which is undesirable.

Expected Results:  
NEVER post data twice without giving the user the option to prevent it.

File>SaveAs must not go to the server, but use the page as it was delivered, even when it is not cached.

FF versions <1.5.0.6 did not show this behavior.

Comment 1

12 years ago
I'm seeing this in Firefox 1.0.8 as well. Which versions did you test that don't have the bug?
(Reporter)

Comment 2

12 years ago
(In reply to comment #1)
> I'm seeing this in Firefox 1.0.8 as well. Which versions did you test that
> don't have the bug?
> 
I didn't explicitly test this with other versions, but I did notice it appear when I started using this version 1.5.0.6.  So I'd have to answer 1.5.0.x (where x<6).  I am not in a position to verify it with older versions now.
(Reporter)

Comment 3

12 years ago
(In reply to comment #2)
> (In reply to comment #1)
> > I'm seeing this in Firefox 1.0.8 as well. Which versions did you test that
> > don't have the bug?
> > 
> I didn't explicitly test this with other versions, but I did notice it appear
> when I started using this version 1.5.0.6.  So I'd have to answer 1.5.0.x
> (where x<6).  I am not in a position to verify it with older versions now.
> 
I just tested it with 1.5.0.6 and 1.5.0.4 on an old W98 machine.  Where 1.5.0.6 produces the error, 1.5.0.4 does not.  Instead it appears to be using another mechanism - you see the Download result window appear after a File>SavePageAs.

(Reporter)

Comment 4

12 years ago
Here is more important info: the problem only seems to occur when the SaveAs option "Web page, HTML only" is selected.  It does NOT occur when "Web Page, complete" is chosen.

I am no longer sure that it did not occur in older versions also.

Updated

11 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Keywords: testcase
Resolution: --- → DUPLICATE
Duplicate of bug: 115174
You need to log in before you can comment on or make changes to this bug.