Tamil unicode characters are not rendered correctly

RESOLVED INVALID

Status

()

RESOLVED INVALID
12 years ago
12 years ago

People

(Reporter: rshanmugas, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051111 Firefox/1.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051111 Firefox/1.5

Please view the following html page in Firefox and Internet Explorer. Firefox renders it wrongly.

<html>
<body>
&#2970;&#3018;
</body>
</html>


Reproducible: Always

Steps to Reproduce:
1. Create tamil.html using notepad (or any of your favourite editor)
2. Paste the following html content
<html>
<body>
&#2970;&#3018;
</body>
</html>
3. View it in Firefox (I tested it on 1.5)
4. View it in Internet Explorer (I tested it on Internet Explorer 7 beta 2)
5. View it in Microsoft Word, using Arial Unicode MS font (I tested on Word 2003)
6. You will see that Firefox renders it wrongly



Actual Results:  
The glyphs are mixed up.

Expected Results:  
The glyphs should appear in the correct order, as they appear in Internet Explorer and Microsoft Word.
The test case works for me. 

Is complex script enabled in your installation of Windows (in Settings | Control Panel | Regional and Language Options | Languages, is the checkbox "Install files for complex script and right to left languages.." checked?). IE supports complex script even if it's not enabled in the OS, but Firefox relies on the OS support.
(Reporter)

Comment 2

12 years ago
(In reply to comment #1)

Yes. This seems to solve the problem. Thanks.

Would it be too much to ask this explanation to be put in FAQ?

Regards/Shan

> The test case works for me. 
> 
> Is complex script enabled in your installation of Windows (in Settings |
> Control Panel | Regional and Language Options | Languages, is the checkbox
> "Install files for complex script and right to left languages.." checked?). IE
> supports complex script even if it's not enabled in the OS, but Firefox relies
> on the OS support.
> 

Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED

Comment 3

12 years ago
We used to have that in 'known issues : international' for mozilla suite. See, for instance, http://www.mozilla.org/releases/mozilla1.7/known-issues-int.html#display

Status: RESOLVED → UNCONFIRMED
Resolution: FIXED → ---

Comment 4

12 years ago
see also bug 240914.

Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago12 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.