failed to show item in RSS that encoded in Big5

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
12 years ago
12 years ago

People

(Reporter: koalay, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; zh-TW; rv:1.8.1b2) Gecko/20060821 Firefox/2.0b2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; zh-TW; rv:1.8.1b2) Gecko/20060821 Firefox/2.0b2

I visited the URL. That is a RSS 2.0 news feed encoded in Chinese Traditional (Big5). I can actually see the news items if I view the source code of the page. However, the normal display shows me that the feed is empty.

Reproducible: Always

Steps to Reproduce:
1.start Firefox 2.0 beta 2
2.visit RSS feeds in http://www.mpinews.com
(for example - http://www.mpinews.com/RSS/INews/gb.xml)

Actual Results:  
nothing shown up

Expected Results:  
some news item should be shown

I can see the same feed with flock.
I supposed the problem has nothing to do with RSS 2.0 standard
Component: Bookmarks → RSS Discovery and Preview
QA Contact: bookmarks → rss.preview

Comment 1

12 years ago
Works for me "Mozilla/5.0 (Windows; U; Windows NT 5.1; zh-TW; rv:1.8.1b2) Gecko/20060821 Firefox/2.0b2"

Comment 2

12 years ago
Created attachment 238332 [details]
WFM

Updated

12 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 3

12 years ago
It works now. The last time I read the RSS, Mozilla Firefox forced me to use UTF-8 to read it. I think it may be a server setting problem (on HTTP header) that they have solved.

Thanks
You need to log in before you can comment on or make changes to this bug.