software update does not resume where it left off after computer shutdown

RESOLVED DUPLICATE of bug 304454

Status

()

Toolkit
Application Update
RESOLVED DUPLICATE of bug 304454
12 years ago
9 years ago

People

(Reporter: juanb, Unassigned)

Tracking

1.8 Branch
mozilla1.8.1
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1b1) Gecko/20060710 Firefox/2.0b1

Litmus test case 2463. I tried shutting the computer down while a partial update was starting to download. The test case indicates that when you power up the computer and relaunch the application the update download should resume in the background. The update download resumes after a while, but it doesn't resume from where it left off, and in fact seems to start downloading a complete update.

To reproduce:
1. Download and install 2.0b1 and check for updates.
2. Start the update and shutdown your machine while it is downloading (I pressed the power button).
3. Restart your machine and relaunch your application.
4. Observe the size of the update.mar file.

Expected: The partial update download should resume where it left off before the computer was shutdown, and the update.mar file should keep growing in size.

Actual: The update.mar file does not grow, and after a while it starts again from zero. And if you look at the update.xml file, it looks like the application considers the partial download a fail, and starts downloading a complete update.
(Reporter)

Comment 1

12 years ago
Created attachment 236422 [details]
updates.xml file after computer shutdown/restart and application relaunch
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit

Updated

9 years ago
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 304454
You need to log in before you can comment on or make changes to this bug.