Status

()

--
critical
RESOLVED DUPLICATE of bug 241518
12 years ago
12 years ago

People

(Reporter: bugzilla, Unassigned)

Tracking

unspecified
x86
Windows XP
Points:
---
Bug Flags:
blocking1.8.0.7 -

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.6) Gecko/20060728 Firefox/1.5.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.6) Gecko/20060728 Firefox/1.5.0.6

Go to any page which refreshes every 5-10 seconds, leave it over night, Mozilla will be taking up all available memory.

Reproducible: Always

Steps to Reproduce:
1. Go to any page which refreshes every 5-10 seconds
2. Leave it overnight
3. View Memory Footprint

Actual Results:  
Took up all memory available

Expected Results:  
Take up very little memory

Probably a side effect, but its also chewing up huge CPU resources, probalby under the weight of its memory.
Don't happen for me, neither with branch nightly, nor with 1.5.0.6 on MacOS and on WinXPSP2.

Do you have a specific link where it happens?
(Reporter)

Comment 2

12 years ago
Yes but unfortunately its not a publicly accessable page, I'll see if I can reproduce w/ no extensions enabled as well.  I'll come up with a test page today that is accessable and post here.
(Reporter)

Comment 3

12 years ago
Okay, I have a fairly reduced test case, its definetely involved in JavaScript.

http://www.eyeoftheart.com/firefox_leak.htm

I have the page setup to refresh after 0 seconds, let it run for 20 minutes you'll see the leak.
(Reporter)

Updated

12 years ago
Flags: blocking1.8.0.7?
Clint, can you try with the 2006-09-12 firefox 2 nightly build and see if this is still a problem for you? thanks!
- http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2006-09-12-03-mozilla1.8/
You should make a new profile for 2.0 post-beta-2 nightly so it doesn't effect your 1.5 profile.
(Reporter)

Comment 5

12 years ago
I just tried it with the link you sent over, seems to be fine.  Interestingly enough it does seem to slow down on the re-loads but it does not cause any memory leaks, nor does the CPU continue to crank at 50% when you stop the reloading process.  

Looks all good in the 2.0 version, nice!  Should I expect no change for the 1.5x line then?

Thanks!
Without knowing exactly what bug your testcase is tripping over, I can't say if it will get fixed for firefox 1.5.0.x or not. It might be bug 241518 which was fixed for firefox 2.0, but doesn't look like it was backported or landed for 1.5, but like I said, it may be another bug you're seeing so I could be wrong.
(Reporter)

Comment 7

12 years ago
Indeed, it is the same bug, removing the events fixes the problem.  Thanks!

*** This bug has been marked as a duplicate of 241518 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
1.8.0.7 has left the building...
Flags: blocking1.8.0.7? → blocking1.8.0.7-
You need to log in before you can comment on or make changes to this bug.