Closed Bug 351114 Opened 14 years ago Closed 14 years ago

GTK Theme problems with Linux (also in 1.5)

Categories

(Firefox :: Shell Integration, defect)

x86
Linux
defect
Not set
trivial

Tracking

()

RESOLVED DUPLICATE of bug 283697

People

(Reporter: jimmygoon, Unassigned)

Details

Attachments

(2 files)

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1b2) Gecko/20060821 Firefox/2.0b2
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1b2) Gecko/20060821 Firefox/2.0b2

In both the latest beta of firefox (beta 2) and in the 1.5.0.6 version there are problems with the GUI and how it integrates with Linux's (Ubuntu's) GTK2 engine.

First, in the preference window, it consistently pops up too small to see all options. This is slightly annoying and could be problem-some for people that don't have quite small fonts as I do.

Secondly, On the last tab of the preferences window, all of the GUI components: labels, text boxes, check boxes etc... seem to be miss-themed... Check the screenshots for more info.

Reproducible: Always

Steps to Reproduce:
1. Edit -> Preferences
2. Look Closely

Actual Results:  
It looks bad.

Expected Results:  
It should look good.

Ubuntu Dapper 6.06.1
Firefox 1.5.06
Firefox 2.0 beta 2
Attached image Showcases the problem
Attached image Also showcases!
Things get wacky when people use non-default sized fonts (on both Linux and Windows). Unfortunately, we don't have a good solution for this problem yet.

*** This bug has been marked as a duplicate of 283697 ***
Status: UNCONFIRMED → RESOLVED
Closed: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.