Firefox closes all open windows if x-ing out still active dialog manager

RESOLVED WORKSFORME

Status

()

--
critical
RESOLVED WORKSFORME
13 years ago
11 years ago

People

(Reporter: bwmarcotte, Unassigned)

Tracking

1.8.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: CLOSEME 07/09)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.6) Gecko/20060728 Firefox/1.5.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.6) Gecko/20060728 Firefox/1.5.0.6

If I do not wait long enough to make sure the download manager is no longer doing anything and click on the X to close the download window all my firefox windows will close.  I have experienced this problem since I started using firefox (multiple versions).

Reproducible: Always

Steps to Reproduce:
1. Begin download
2. Cancel download
3. since no hourglass showing to indicate download window busy, x out download window.



Actual Results:  
Firefox will close all windows except download window first then that will close too.  Watch the taskbar you will see after the firefox windows close there will remain one firefox item "download" then that will disappear.

Expected Results:  
Either presented me with an hourglass to indicate the download dialog was busy or not allow me to close the window until the download dialog has completed processing.

standard firefox theme
There is no reported crash either by firefox or by windows.
Reporter, do you still see this problem with the latest Firefox 2? If not, can you please close this bug as WORKSFORME. Thanks!
Whiteboard: CLOSEME 07/09
Version: unspecified → 1.5.0.x Branch
(Reporter)

Comment 2

12 years ago
With version 2.0.0.4 I can not reproduce this bug.  Bug closed.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME
(Assignee)

Updated

11 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.