arrow does not change to finger over URL

VERIFIED FIXED

Status

Thunderbird
General
--
minor
VERIFIED FIXED
12 years ago
11 years ago

People

(Reporter: Leo Tick, Assigned: Peter Weilbacher)

Tracking

({verified1.8.1.8})

Trunk
x86
OS/2
verified1.8.1.8

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (OS/2; U; Warp 4.5; en-US; rv:1.8.0.6) Gecko/20060803 Firefox/1.5.0.6
Build Identifier: Mozilla/5.0 (OS/2; U; Warp 4.5; en-US; rv:1.8.0.6) Gecko/20060803 Firefox/1.5.0.6

When the arrow cursor moves over a URL it chnges to a finger.
This is not happening in TB 1.5 OS2. OK in win.
On the lower bar the display reflects the URL but no finger.

Reproducible: Always

Steps to Reproduce:
1.move cursor over a URL
2.
3.

Actual Results:  
Arrow stays arrow

Expected Results:  
arrow should be finger
(Assignee)

Comment 1

11 years ago
Indeed that is happening here, too, and still with TB 2.0.0.x and with TB from the current trunk.

It seems to be a build problem, the mouse shape for the different pointers is just not contained in the thunderbird executable.
Severity: normal → minor
Status: UNCONFIRMED → NEW
Ever confirmed: true
Hardware: Other → PC
Version: unspecified → Trunk
(Assignee)

Comment 2

11 years ago
Created attachment 270483 [details] [diff] [review]
[checked in] Fix

This patches the files in mail/app similar to what Firefox and Sunbird already have, for TB it was probably just forgotten. The difference is that specifying a .def file breaks the compilation, so I left it out and it seems to work fine.

I think we can also remove widget/src/os2/resource.h from CVS. I'm still running a compilation to confirm that.
Assignee: mscott → mozilla
Status: NEW → ASSIGNED
Attachment #270483 - Flags: review?(mozilla)
(Assignee)

Comment 3

11 years ago
Created attachment 270502 [details] [diff] [review]
[checked in] Remove unused widget/src/os2/resource.h

All other parts of the code that refer to resource.h point to another one (well, at least those that I found). A build succeeds without it.
Attachment #270502 - Flags: review?(mozilla)

Comment 4

11 years ago
Comment on attachment 270483 [details] [diff] [review]
[checked in] Fix

r=mkaply
Attachment #270483 - Flags: review?(mozilla) → review+

Comment 5

11 years ago
I thought resource.h was still used for non static builds? Like seamonkey? where we look for the pointers/etc. in the DLL, not the EXE...
(Assignee)

Comment 6

11 years ago
Then it should be referenced somewhere in widget\src\os2 but I don't see it there. Only wdgtos2rc.h is used and that contains the same stuff in resource.h. OK, it seems that the checkin
http://bonsai.mozilla.org/cvsquery.cgi?date=explicit&mindate=2004-02-24+15%3A11&maxdate=2004-02-24+15%3A12
did the change but couldn't yet remove the file because of its usage elsewhere (like in mail/app).

But we can leave this part open until I have made another full build here, the FF debug builds I do are shared.
(Assignee)

Comment 7

11 years ago
Comment on attachment 270483 [details] [diff] [review]
[checked in] Fix

Checked this into trunk. Leaving bug open for the resource.h patch.
Attachment #270483 - Attachment description: Fix → Fix (checked in)
Attachment #270483 - Attachment description: Fix (checked in) → [checked in] Fix
(Assignee)

Comment 8

11 years ago
mkaply, I now built a full SeaMonkey and it works fine without resource.h.

Comment 9

11 years ago
Comment on attachment 270502 [details] [diff] [review]
[checked in] Remove unused widget/src/os2/resource.h

r=mkaply
Attachment #270502 - Flags: review?(mozilla) → review+
(Assignee)

Comment 10

11 years ago
Comment on attachment 270502 [details] [diff] [review]
[checked in] Remove unused widget/src/os2/resource.h

Removed file on trunk.
Attachment #270502 - Attachment description: Remove unused widget/src/os2/resource.h → [checked in] Remove unused widget/src/os2/resource.h
(Assignee)

Updated

11 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
(Assignee)

Comment 11

11 years ago
Comment on attachment 270483 [details] [diff] [review]
[checked in] Fix

This has worked on trunk, so we also want it in the next branch release. (Well contained OS/2 only patch, I ask because I also change something in a cross-platform makefile.)
Attachment #270483 - Flags: approval1.8.1.6?
Comment on attachment 270483 [details] [diff] [review]
[checked in] Fix

approved for 1.8.1.7, a=dveditz for release-drivers
Attachment #270483 - Flags: approval1.8.1.7? → approval1.8.1.7+
(Assignee)

Comment 13

11 years ago
Checked in attachment 270483 [details] [diff] [review] to MOZILLA_1_8_BRANCH, so the official Thunderbird 2.0.0.7 release should have the fix.
Keywords: fixed1.8.1.7
(Assignee)

Comment 14

11 years ago
Leo, could you get the current nightly build of Thunderbird from

http://ftp.mozilla.org/pub/mozilla.org/thunderbird/nightly/contrib/latest-mozilla1.8/thunderbird-2.0.0.7pre.en-US.os2.zip

and see if the problem is fixed?
(Assignee)

Comment 15

11 years ago
Leo confirmed to me by email that it is fixed for him, too. :-)
Status: RESOLVED → VERIFIED
Keywords: fixed1.8.1.7 → verified1.8.1.7
You need to log in before you can comment on or make changes to this bug.