Ability to create new folders when creating a filter is gone in 1.5x,2.x

RESOLVED DUPLICATE of bug 308660

Status

Thunderbird
General
--
enhancement
RESOLVED DUPLICATE of bug 308660
12 years ago
11 years ago

People

(Reporter: Scott, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1b2) Gecko/20060821 Firefox/2.0b2
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1b2) Gecko/20060821 Firefox/2.0b2

In Thunderbird versions prior to 1.5 (in both Windows and Linux) you could create a new folder from the same dialogs you were using to create a new filter.  For example, if you wanted messages from "Bob" to be moved to the "Bob" folder upon arrival AND you didn't yet have a "Bob" folder created, you could do this all in one step.

That's been gone since 1.5.

Now you have to create the folder first and THEN create the filter in two seperate transactions.  It was much simpler before.  It's quite annoying now.

Reproducible: Always

Steps to Reproduce:
1. Create a new filter
2. Under "Perform these actions" select either "copy message to" or "move message to"
3. Select the folder menu and note there is no way to create a folder to move the message to. You have to use an existing one.

Actual Results:  
See #3 Above.

Expected Results:  
A create new folder option would be there along with the options to move/copy to an existing folder.

See "Expected Results".  This is how it worked in Thunderbird prior to 1.5.

I'd love to know the logic behind taking something that was good and removing it.

Comment 1

11 years ago
I can't see any reason for the removal of such an important feature except for an oversight or malice.  

And why is this labelled 'unconfirmed'?  I can confirm the behaviour here with version 1.5.0.7 (20060913)/linux and version 1.5.0.5 (20060719)/win32 but we're told it's bad etiquette to post 'me too' comments.

Can someone here please assign this bug and change its severity to 'normal' since this is a regression fix?

Comment 2

11 years ago
This is a dupe of bug 308660.

*** This bug has been marked as a duplicate of 308660 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.