Text in non-highlighted/current tab is hard to read.

RESOLVED WORKSFORME

Status

()

Firefox
Tabbed Browser
--
enhancement
RESOLVED WORKSFORME
11 years ago
9 years ago

People

(Reporter: Kingsly John, Unassigned)

Tracking

2.0 Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1b2) Gecko/20060821 Firefox/2.0b2
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1b2) Gecko/20060821 Firefox/2.0b2

On Linux(w/default GTK theme) the contrast on the regular/non-current tabs
is very poor  making it strenuous to read them.

    As you can see in the image below, the 3 tabs are in 3 different levels of
contrast.(the first one is a regular tab.. the second one is with
hover/mouseover and the last is the current tab.)

    http://img520.imageshack.us/my.php?image=ffox2b2qz7.png

    The current tab is the most legible/clear one and the only time I tend to
look at the tabs is when I'm looking to switch to another tab and it takes too
much effort to read the text in those tabs.

Compare readability with the same fonts used in the bookmarks/menu toolbars.

Even in the new theme concept mockups the contrast of the fonts is not affected
and they look perfectly legible.

http://wiki.mozilla.org/Image:Fx2-new-theme-concept-tabs.png

IMO normal vs bold is good enough to differentiate between the current tab
and others. maybe a leave the other tabs in the regular background color and
make the current one white/bright. but there's no need to make the fonts
duller.


Reproducible: Always




There seems to be a windows bug report that is almost similiar but the tabs don't look as bad/unreadable on the screenshots I see there as they do on my desktop.

https://bugzilla.mozilla.org/show_bug.cgi?id=350690

Updated

11 years ago
Severity: normal → enhancement
Version: unspecified → 2.0 Branch

Comment 1

9 years ago
I think this was probably fixed - 2 branche is now unmaintained - so closing.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED

Updated

9 years ago
Resolution: FIXED → WORKSFORME
You need to log in before you can comment on or make changes to this bug.