Options > Feeds > Choose Application line too short when text size is large

RESOLVED DUPLICATE of bug 351133

Status

()

RESOLVED DUPLICATE of bug 351133
12 years ago
12 years ago

People

(Reporter: ehume, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1b2) Gecko/20060903 BonEcho/2.0b2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1b2) Gecko/20060903 BonEcho/2.0b2

In Options > Feeds > Choose Application, the line is too short when a larger text size is used. The Choose Application button is cut off by the right edge of the listbox.

Reproducible: Always

Steps to Reproduce:
1. Set Windows XP to Large Fonts (125%), with Message Box = 10
2. Open Options to the Feeds tab.
3. Observe the No Application Selected line

Actual Results:  
The Choose Application button is cut off by the right edge of the listbox.

Expected Results:  
The Choose Application button should have stayed within the right edge of the listbox.

Stretching the Options window to the right does not expose the whole Choose Applications button.
(Reporter)

Comment 1

12 years ago
Created attachment 236649 [details]
Options > Feeds with Windows Large fonts and message Box = 10
(Reporter)

Comment 2

12 years ago
Comment #1 should have read Message Box = 10.

I tried a kludge for a temp fix.

Based on what I could glean from DOMi - that the boxes and listcolumns are content boxes, I decided that the problem comes from the fact that in Firefox, scrollbars live inside their boxes, and the right edge of the button was covered by the scrollbar. Hence:

/* temp fix for bug #351241 */
#chooseClientApp {
  -moz-margin-end: 20px;
}

This works in browser/preferences/preferences.css, but not in global/preferences.css. For my larger themes, I will likely have to put in a larger margin.
(Reporter)

Updated

12 years ago
Attachment #236649 - Attachment description: Options > Feeds with Windows Large fonts and message Box = 8 → Options > Feeds with Windows Large fonts and message Box = 10

Comment 3

12 years ago

*** This bug has been marked as a duplicate of 351133 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.