Keyboard focus stays on previously selected tab after dragging link to diff. tab

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
13 years ago
12 years ago

People

(Reporter: FirasE, Unassigned)

Tracking

2.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1b2) Gecko/20060821 Firefox/2.0b2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1b2) Gecko/20060821 Firefox/2.0b2

If you have more than one tab open in FF, and drag a link that is shown on one tab onto the another tab, so the link opens in that tab, then click on the tab you just dragged the link to and hit PageDown (on the keyboard), the tab that you dragged the link from receives the PageDown and the new tab doesn't scroll.

Reproducible: Always

Steps to Reproduce:
1. Have two tabs open in Firefox
2. On tab #1, go to a site which contains links
3. Drag a link from tab #1 to tab #2
4. Click on tab #2
5. Hit PageDown on the keyboard
6. Notice nothing happens on tab #2
7. Click back to tab #1 and notice that it scrolled down

Actual Results:  
Originating tab scrolls instead of new tab

Expected Results:  
The tab I was actually viewing (tab #2) should have scrolled down.

Comment 1

13 years ago
Seems to WFM on "Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1b2) Gecko/20060903 BonEcho/2.0b2"
I am able to occasionally reproduce this bug with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1b2) Gecko/20060903 BonEcho/2.0b2 ID:2006090304

I have noticed that it is related to switching between tabs and clicking in the tab content as well as focusing the actual tab. After doing this for a while, I drag a link to the second tab and switch tabs while the content is still being loaded. PageUp and PageDown events are then sent to the first tab. I am not able to reproduce using the steps in the description but unfortunately I'm not able to provide more consistent steps to reproduce.
(Reporter)

Comment 3

12 years ago
Arie reminded me that it always included a video player (Qt or WMP) loading in the tab. So here's the corrected instructions, which I can now repro fully.

1. Open FF and go to http://www.funny-games.biz/videos/
2. Go to File -> New Tab
3. On the new tab, go to yahoo.com
4. Go back to tab 1, and drag one of the video pictures (near the top of the page) to tab 2
5. On tab 2, WMP should load in the page
6. Hit the Back button (on tab 2) so it returns to yahoo
7. Now go to tab 1, and drag another link onto tab 2
8. Switch to tab 2 (but don't click inside the page itself) and hit PageDown
9. Nothing happens, but tab 1 scrolls down

Comment 4

12 years ago
(Michael Rywalt, 9/10/06)

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.6) Gecko/20060728 Firefox/1.5.0.6

and,

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.6) Gecko/20060728 Firefox/1.5.0.6

This bug is always reproducible for me under both Windows and Linux using an alternative set of replication steps listed here:

1. Open two tabs in FireFox
2. Load www.google.com into first tab and perform a search on any subject
3. Load www.yahoo.com into second tab, do not perform a search
4. Click on the first tab, then click and drag a google search result to the second tab.
5. Click on the second tab, then press Page Down a few times (nothing happens on this tab)
6. Now click on the first tab again, and notice the google results page has scrolled down.

Reporter, do you still see this problem with the latest Firefox 2? If not, can you please close this bug as WORKSFORME. Thanks!
Whiteboard: CLOSEME 07/09
Version: unspecified → 2.0 Branch
This is WFM tested Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a7pre) Gecko/2007071105 ID:2007071105

Reporter or anyone else, if you still see this problem with the latest Firefox 2 and/or Firefox 3/Trunk Version please reopen this bug.
Closing as WORSKFORME due to lacking Feedback and/or Steps to Reproduce.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME
Whiteboard: CLOSEME 07/09
You need to log in before you can comment on or make changes to this bug.