Exception in browser.xml and tabbrowser.xml when closing multiple tabs

RESOLVED DUPLICATE of bug 289035

Status

()

RESOLVED DUPLICATE of bug 289035
12 years ago
9 years ago

People

(Reporter: whimboo, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
Because I don't work on trunk I can only see the exceptions with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1b2) Gecko/20060903 BonEcho/2.0b2.

To reproduce you have to open a lot of tabs (appr. 20) and close them directly by holding down the ctrl+w keys. After the last tab is closed following two exceptions are thrown multiple times:

Error: uncaught exception: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIDOMXULElement.boxObject]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: chrome://global/content/bindings/browser.xml :: get_docShell :: line 0"  data: no]

Error: uncaught exception: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIDOMXULElement.boxObject]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: chrome://global/content/bindings/tabbrowser.xml :: _notifyBackgroundTab :: line 2865"  data: no]

Comment 1

12 years ago
Steps to reproduce:
1. Disable the option "Hide the tab bar when only one tab is open".
2. Hold down Ctrl+W for a few seconds.

This also works with only one tab open. At least the second error is triggered by the call to _notifyBackgroundTab from a timeout set in addTab which is triggered at a point where the tab has already been closed again. Replacing

(aTabContainer.selectedItem != t)

with

(t.parentNode && aTabContainer.selectedItem != t)

in addTab fixes the second error.

Updated

11 years ago
Duplicate of this bug: 383735

Updated

9 years ago
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 289035
You need to log in before you can comment on or make changes to this bug.