Loading images should have transparent background

VERIFIED DUPLICATE of bug 1248

Status

()

Core
Layout
P3
normal
VERIFIED DUPLICATE of bug 1248
18 years ago
18 years ago

People

(Reporter: hand, Assigned: dcone (gone))

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
When the browser is loading images, sometimes the unloaded parts of the images 
are either black or contain mostly black garbage.  This usually occurs when the 
page is hidden behind another window while loading, then brought to front again 
before all the images on the page have been loaded.

This effect is worst when the browser fails to completely load an image causing 
the unsightly unloaded parts to stay permanently.  (I would not classify not 
being able to load an image properly as a bug - after-all, networks aren't 
always reliable, but see bug #35130.)

So again, a transparent background for unloaded portions of images would be 
ideal.  A coloured background matching the background colour of the page or the 
background colour of the element in which the image is contained is less than 
ideal but preferable to garbage or black.

Updated

18 years ago
Assignee: troy → dcone

Comment 1

18 years ago
Don, I thought this problem was fixed? Is the fix in PR1?

Comment 2

18 years ago
Testing with 2000-04-06-10-M15 and 2000-04-07-09-M15 on WinNT viewing a variety
of graphics-rich sites while doing a download at the same time to keep loading
slow, I saw no problem with unloaded parts of images containing black
or garbage.

hand@syd.speednet.com.au, please consider using the Bugzilla helper at
http://www.mozilla.org/quality/help/bug-form.html to file bug reports,
and in any case follow the Bug Writing Guidelines at 
http://www.mozilla.org/quality/bug-writing-guidelines.html -- in particular,
because bugs get fixed every day, it is necessary to report the Build ID
(the number resembling 2000040709 at the bottom right of the browser window)
if you do not use the Bugzilla Helper.

Marking as a DUP of bug 1248, "[Perf]Bottommost portion of images filled 
w/garbage during rendering", FIXED.

*** This bug has been marked as a duplicate of 1248 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
QA Contact: petersen → elig
Resolution: --- → DUPLICATE

Comment 3

18 years ago
Rubber-stamping as verified duplicate, pending hand@syd.speednet.com.au providing 
information to the contrary on a current build.

Thanks, Sean!
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.