mozilla doesn't migrate 4.x profile completely

VERIFIED DUPLICATE of bug 14645

Status

Core Graveyard
Profile: Migration
P3
normal
VERIFIED DUPLICATE of bug 14645
18 years ago
2 years ago

People

(Reporter: Douglas Lee, Assigned: dbragg)

Tracking

Trunk
x86
Windows 95

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win95; en-US; m14)
BuildID:    2000040708

I installed builds from the past two days (April 6-7), and I found that for some
reason the 4.x profile didn't get properly migrated to mozilla.  When mozilla
asked to convert the profile, normally it takes a few seconds to do its job, but
I've seen it take like 1 second to "migrate" and then it's done.  It copied my
name okay but not the bookmarks.

Reproducible: Sometimes
Steps to Reproduce:
1. Install mozilla and convert a 4.x profile
2.
3.

Actual Results:  mozilla "converts" the profile too quickly (about 1 second)

Expected Results:  mozilla should take about 3-4 seconds to convert (at least on
my P133 it has with previous builds of mozilla).

I marked this as "sometimes reproducible" because when I installed mozilla those
couple of times when it was too quick a profile conversion, I had been running
and closing apps all day (e.g. Netscape 4.72, mIRC, GetRight, etc.).  When I
installed mozilla from a fresh reboot of the computer, the profile conversion
worked fine.

Comment 1

18 years ago
reassigning to selmer
Assignee: ssu → selmer

Comment 2

18 years ago
dwlee2, I notice one of the apps you were running all day was Nav 4.72.  Did you
verify that your bookmarks were correct in the profile *before* you migrated it.
 Were you migrating a just-created profile or one that'd been around in 4.72 for
a while?  I need more information to help narrow down the possibilities.
Assignee: selmer → racham
(Reporter)

Comment 3

18 years ago
Nope, the older 4.x profile wasn't just created.  It was around when Netscape 
was at 4.6 and it's the same one that I'm using now, in 4.72.  The bookmarks 
were verified in 4.72 but they never showed up after the migration-conversion to 
mozilla.  All I can say is that the migration-conversion was too quick when I 
immediately ran the mozilla installer after my computer's been doing other 
things, but it worked okay after I did a fresh reboot of the computer.
(Reporter)

Comment 4

18 years ago
UPDATE: I found I can reproduce this bug on demand, but the 
previously mentioned circumstances are different.  It's not about a fresh 
reboot, etc.  It's about what is installed when running the 
mozilla-win32-installer.exe program.  In the times that the profile didn't get 
migrated properly, I had chosen a Custom setup, and not to install Mail and 
News.  That's when the profile was converted very quickly (and without the 
bookmarks).  When I installed it completely (mozilla + Mail and News), the 
conversion process took the original length of time, and the bookmarks were 
migrated properly.

Comment 5

18 years ago
Looks like migration has some dependencies on mail or some code segment is being 
skipped if the mail is not installed. Reassigning to Don Bragg. Adding Seth to 
cc list.
Assignee: racham → dbragg
Component: Installer → Profile Migration
this sounds like bug #14645.  I'll read carefully, and mark duplicate if it is.
yeah, this is a dup.  but this is an excellent bug report, with plenty of
details to help me track down and squash this bug.


*** This bug has been marked as a duplicate of 14645 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 8

18 years ago
Anyway, I think this may be somewhat related, but I opened a separate bug report 
on it.
The addressbook doesn't get carried over in the profile migration, even if the 
profile was properly migrated.
I wrote up bug 35242 about the addressbook (but I think that someone's already 
beaten me to the punch on this one, even though I looked through bugzilla and 
didn't find any bug reports on the addressbook failing to migrate).

Comment 9

18 years ago
ok
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.