Closed Bug 351323 Opened 14 years ago Closed 14 years ago

Can't see content of dropdown menu in 'More' section of event/task dialog

Categories

(Calendar :: Calendar Views, defect)

x86
All
defect
Not set
major

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: omarb.public, Assigned: smaug)

References

Details

(Keywords: regression, Whiteboard: [no l10n impact])

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1b2) Gecko/20060902 BonEcho/2.0b2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1b2) Gecko/20060902 BonEcho/2.0b2

When I create a task/event I can't see Privacy, Priority, Alarm

Reproducible: Always

Steps to Reproduce:
1.Select new task/new event
2.If option more is selected select less, exit window and repeat 1 step
3.Click more

Actual Results:  
Can't see Privacy, Priority, Alarm


Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060904 Calendar/0.3a2+
Attached image Actual view
Request blocking 0.3- major function is broken
Flags: blocking0.3?
Confirmed on Linux.
Works in Sunbird/0.3a2+ (2006-09-03-07)
Fails in Sunbird/0.3a2+ (2006-09-04-02)
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression
OS: Windows XP → All
Version: unspecified → Trunk
This was caused by the check in for Bug 348304. I verified by backing out the changes to mozilla/layout/xul/base/src/*.

Because I'm not authorized to access Bug 348304 I'm adding the persons reported by Bonsai to CC here.
Blocks: 348304
Assignee: nobody → Olli.Pettay
Flags: blocking0.3? → blocking0.3+
This bug was reproduced on Mac OSX 10.4.7
Can not use the Alarm dropdown menu because it is cutoff.
After clicking on cutoff Alarm dropdown the Privacy, Priority, and Status are still visible but when click on them no pulldown menu is shown thus they can not be used or changed.
Also Description and URL text areas can not be typed in. When click on either of them the cursor appears and is blinking but text can not be entered.

Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.9a1) Gecko/20060904 Calendar/0.3a2+
Whiteboard: [no l10n impact]
Just a note what happens (I hope this helps to analyze the regression):

If the dialog is loaded some of the xul elements are collapsed/hidden initially. The dialog offers the default disclosure button to show more input fields. This button calls toggleDetails() that removes the collapsed attribute from the xul elements and sets the correct value to the elements. Before the regression the dropdown menus resized automatically to show their content.

Corresponding source:
http://lxr.mozilla.org/mozilla/source/calendar/base/content/calendar-event-dialog.js
http://lxr.mozilla.org/mozilla/source/calendar/base/content/calendar-event-dialog.xul

(In reply to comment #6)
Description and URL text field work for me in Sunbird/0.3a2+ (20060905).
It is most likely caused by the change to make popups with sizetopopup set to resize asynchronously. As the menulist is hidden on initial reflow and has 0 size, the menulist sets it width to 0.
Yes, that it causing it. Unless I find out a fix soon, I'll backout
bug 348304. Now there is anyway a testcase which must work before
bug 348304 can land to branches.
This should be fixed now.
Status: NEW → RESOLVED
Closed: 14 years ago
Resolution: --- → FIXED
Verified with Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a1) Gecko/20060907 Calendar/0.3a2+
Verified with Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/20060907 Calendar/0.3a2+
Status: RESOLVED → VERIFIED

(In reply to Stefan Sitter [:ssitter] from comment #7)

Just a note what happens (I hope this helps to analyze the regression):

If the dialog is loaded some of the xul elements are collapsed/hidden
initially. The dialog offers the default disclosure button to show more
input fields. This button calls toggleDetails() that removes the collapsed
attribute from the xul elements and sets the correct value to the elements.
Before the regression the dropdown menus resized automatically to show their
content.

Corresponding source:
http://lxr.mozilla.org/mozilla/source/calendar/base/content/calendar-event-
dialog.js
http://lxr.mozilla.org/mozilla/source/calendar/base/content/calendar-event-
dialog.xul
https://www.bigbootyporn.tv/top-rated/
(In reply to comment #6)
Description and URL text field work for me in Sunbird/0.3a2+ (20060905).

good job

You need to log in before you can comment on or make changes to this bug.