change application UI font size

VERIFIED WONTFIX

Status

Camino Graveyard
Accessibility
VERIFIED WONTFIX
12 years ago
12 years ago

People

(Reporter: jonathan chetwynd, Unassigned)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
Camino should follow the OS font size, however in OS X it isn't currently possible to change the OS font size :-) though see tinkertool later.

In the meantime there should be a preferences panel for changing the font size used in toolbars including the menu text labels and address bar.

Not everyone will know of tinkertool or be happy to use it.
however I increased all font size options by 4 or 5 pts. with little obvious change to camino bar the title and tab captions. please note the white space or height is not increasing to match the font size for these.


https://bugzilla.mozilla.org/show_bug.cgi?id=351316
is related bug in ff, but currently marked as dupme.
(Reporter)

Comment 1

12 years ago
Created attachment 236789 [details]
image showing tinkertool and camino
I could have sworn we already had a bug on respecting UI scaling (including font size)...
Bug 258553 is our existing bug on respecting UI scaling and changing system font sizes (we do the latter, except for that one issue, and the similar clipping here).

We likely won't fix issues with individual font size changes, but these should be fixed by supporting res-independent UI anyway.

*** This bug has been marked as a duplicate of 258553 ***
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE

Comment 4

12 years ago
I agree with bug 258553 comment 15; this isn't a dup, since what it primarily wants is Camino-specific UI for changing just Camino's font size--which will never happen, for all the reasons explained in the FF bug.

Resolution-independent UI is clearly the direction Apple is going to solve this problem at a system-wide level, so supporting that is the way Camino will go.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---

Updated

12 years ago
Status: REOPENED → RESOLVED
Last Resolved: 12 years ago12 years ago
Resolution: --- → WONTFIX
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.