If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

wait until the user is idle before showing the software update window

VERIFIED DUPLICATE of bug 323041

Status

()

Toolkit
Application Update
VERIFIED DUPLICATE of bug 323041
11 years ago
9 years ago

People

(Reporter: (not reading, please use seth@sspitzer.org instead), Unassigned)

Tracking

1.8 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

wait until the user is idle before showing the software update window.

I really dislike it when the software update popups while I'm doing something with the application (firefox or tbird).  There are a bunch of bugs related to when this happens.

I vaguely remember the old Netscape AIM xul implementation had a way to determine idle state.  The underlying service that figured that out may still be available.
related to Bug 347585 which may remove the need for this bug
Also related is this pair: bug 335798, bug 334767.

They're a bit convoluted, but the basic idea is that it would be less obtrusive if we asked the user when they start the browser, instead of while they're in the middle of using it. But that's FF3 fodder... This bug might be something possible for FF2.

If there's no easy way to determine when the user is "idle", another method might be to wait to show the popup until the user navigates to a new page. A complaint in some other bug was that if the update pops up while you're typing furiously, you might not notice and accidentally trigger the "restart now" button. In theory that shouldn't happen if you're going to a new page...
for the trunk / firefox 3, we can use the idle service to wait before popup up the dialog.

that service is not available on the MOZILLA_1_8_BRANCH.
Blocks: 394021

Updated

10 years ago
No longer blocks: 394021
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 323041
Status: RESOLVED → VERIFIED
(Assignee)

Updated

9 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.