Status

Core Graveyard
Widget: OS/2
RESOLVED FIXED
12 years ago
4 years ago

People

(Reporter: Peter Weilbacher, Assigned: Peter Weilbacher)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

12 years ago
With the threading changes in May 2006 the handling of WM_QUIT that previously lived in nsAppShell::Exit and nsAppShell::Run has gone away. The symptom is that when a SeaMonkey or Firefox window is closed from the Window List of the system nothing happens (besides that window getting focus).

Solutions would be to resurrect the code that was removed and put it into some other method or to just handle WM_QUIT like WM_CLOSE.
(Assignee)

Comment 1

12 years ago
Created attachment 236871 [details] [diff] [review]
The easy fix

Mike, please tell me if this easy fix makes sense to you (at least my limited testing does't show any bad effects), or if I should look into getting the old code back into OS/2's nsAppShell somehow.
Assignee: mozilla → mozilla
Status: NEW → ASSIGNED
Attachment #236871 - Flags: review?(mozilla)

Comment 2

12 years ago
If you have multiple windows open and right click on one in the task list and select close, does it close all or just the one (with this patch)
(Assignee)

Comment 3

12 years ago
In my testing with this patch it closed the one selected window only.

Comment 4

12 years ago
Related to bug 344440?
(Assignee)

Comment 5

12 years ago
Mats, yes the reason for the problem is the same. But I think we should not solve the problem in the same way as it has been done on Windows (in bug 344309) because that will shut down the app completely without asking instead of just closing a window. The solution that was suggested in bug 344440 does not seem to work, either. nsIAppStartup::Quit(eAttemptQuit) always just closes without asking while Quit(eConsiderQuit) doesn't seem to do anything.

I think the solution in attachment 236871 [details] [diff] [review] is better, but I don't know all the implications that this will have when installing and on extensions.
(Assignee)

Comment 6

12 years ago
mkaply, are you happy with the simple solution? If yes, we should get this in soon, because the nightly users get more and more unhappy about this.

Comment 7

12 years ago
Comment on attachment 236871 [details] [diff] [review]
The easy fix

Yep. This is good enough for now.
Attachment #236871 - Flags: review?(mozilla) → review+
(Assignee)

Comment 8

12 years ago
OK, fix checked into trunk (not needed for branch).
Status: ASSIGNED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.