If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Remove nsXULTreeAccessibleWrap and nsXULMenuAccessibleWrap headers (for those that don't need it)

RESOLVED WONTFIX

Status

()

Core
Disability Access APIs
RESOLVED WONTFIX
11 years ago
11 years ago

People

(Reporter: Håkan Waara, Assigned: Håkan Waara)

Tracking

({access})

Trunk
PowerPC
Mac OS X
access
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

11 years ago
The following files can be remove, since the typedefs are not necessary (after a tiny change in nsAccessibilityService.cpp):

for other/ and mac/:
nsXULMenuAccessibleWrap.h
nsXULTreeAccessibleWrap.h

for atk/:
nsXULMenuAccessibleWrap.h
(Assignee)

Comment 1

11 years ago
Created attachment 236961 [details] [diff] [review]
Patch v1

Aaron, I've omitted the Makefile.in change for mac but it's identical to that of other/Makefile.in

I'll make it upon checkin. (I have too many other changes there right now due to my other work.)
Attachment #236961 - Flags: review?(aaronleventhal)

Updated

11 years ago
Keywords: access

Comment 2

11 years ago
Comment on attachment 236961 [details] [diff] [review]
Patch v1

This won't work, let me explain.

We need to create nsXULMenuAccesibleWrap etc. in nsAccessibilityService. In fact, this bug shows me that the remote XUL fix in nsAccessibilityService broke that. We're not creating the Wrap classes we used to.
Attachment #236961 - Flags: review?(aaronleventhal) → review-

Comment 3

11 years ago
So when we fix the regression from bug 241015 where the Wrap classes are no longer being created, it will break this fix because those symbols will no longer be in nsAccessibilityService.
(Assignee)

Comment 4

11 years ago
I wish we could do some kind of fallback that accessible/src/base would use for these wrap classes, so we don't have to have all these boilerplate headers (with only one typedef in them)...
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.