images remain in memory after window/tab close (memory leak)

RESOLVED INVALID

Status

()

Firefox
General
--
major
RESOLVED INVALID
12 years ago
12 years ago

People

(Reporter: bschreibfeder, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.6) Gecko/20060728 Firefox/1.5.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.6) Gecko/20060728 Firefox/1.5.0.6

If firefox is used to open web pages containing images, these images will not be removed from memory after the window or tab containing the page is closed. For example, firefox was used to view images from a high-resolution upload site. Each image was opened in a new window and the window was closed before viewing the next image. After approximately 40 images, firefox's process was using 300MB. Continuing, firefox eventually used more than 1 GB of memory. This resulted in large slow-downs due to paging this much data. To reclaim the memory every firefox window must be closed or the process must be terminated (same effect). With normal page viewing, firefox's process's memory use steadily grows typically requiring an application restart every 2-3 days.

Reproducible: Always

Steps to Reproduce:
1. Find any web site that uses thumbnails or hyperlinks to open high-res images in a new window/tab. (e.g. photobucket/celebrity sites)
2. Open an image then close the window/tab it was opened in.
3. Watch the memory usage of the firefox process in Process Exporer.
4. Repeat and watch the memory usage grow even though the page with each image has been closed.

Actual Results:  
Firefox's memory usage increases until the program must be restarted.

Expected Results:  
Firefox should remove the cached images from it's process's memory (not the same as it's downloaded file cache) after the page containing it is closed or the url changes.

Comment 1

12 years ago
They are removed, but not immediately when a tab is closed. You might want to reopen the tab (Firefox 2.0 allows that). See http://kb.mozillazine.org/Browser.sessionhistory.max_total_viewers on how to tune the cache (which is also used for fast back-and forward navigation).

Updated

12 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.