when software update fails to contact the AUS server, the "manual update link" is not shown

RESOLVED FIXED

Status

Thunderbird
General
RESOLVED FIXED
12 years ago
12 years ago

People

(Reporter: (not reading, please use seth@sspitzer.org instead), Assigned: dietrich)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

when software update fails to contact the AUS server, the "manual update link" is not shown.

I appears that errorLinkLabel is not being set.

See:

http://lxr.mozilla.org/mozilla1.8/source/toolkit/mozapps/update/content/updates.xul#184
http://lxr.mozilla.org/mozilla1.8/source/toolkit/mozapps/update/content/updates.js#1483

note, tbird is defining the correct pref (app.update.url.manual) see

http://lxr.mozilla.org/mozilla1.8/source/mail/app/profile/all-thunderbird.js#77

one thing that has changed recently is we are now using the URL formatter.

See http://lxr.mozilla.org/mozilla1.8/source/toolkit/mozapps/update/content/updates.js#1483

And see https://bugzilla.mozilla.org/show_bug.cgi?id=348076

I haven't debugged this yet, but maybe the url formatter stumbles when the url has no substitutions?

I'll go double check and see if:

1)  ff2 has this bug
2)  if it is indeed a problem with url formatter

Comment 2

12 years ago
this is just another dupe of Bug 350123 if it involves the formatter.

the formatter code doesn't work for non firefox apps as it depends on things that are only built for firefox. 
Assignee: mscott → dietrich
thanks for the info, scott.

I'm going to throw this over the wall to dietrich, since he is working on bug #350123

(It is probably going to be a dup, but I'll let him decide)
OS: Mac OS X 10.3 → All
Hardware: PC → All
(Assignee)

Updated

12 years ago
Status: NEW → ASSIGNED
Depends on: 350123
(Assignee)

Comment 4

12 years ago
fixed by bug 350123
Status: ASSIGNED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.