Closed Bug 351598 Opened 13 years ago Closed 13 years ago

Tasks with date or due date are created/shown multiple times (once for each calendar)

Categories

(Calendar :: Provider: Local Storage, defect)

defect
Not set

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: ssitter, Assigned: mattwillis)

References

Details

(Keywords: regression)

Attachments

(1 file)

Tasks with date or due date are created/shown multiple times (once for each calendar)

Steps to Reproduce:
1. Start Sunbird with clean profile
2. Create several new storage calendars
3. Create one new task that has date, due date or both set
4. Check Task List

Actual Results:
The new task is shown multiple times in Task List, one entry for each existing storage calendar. If you open the Edit Dialog for each of the tasks shown you see that each task has a different calendar set. But all tasks still behave like one. For example changing priority, marking as completed or deleting affects all tasks at once.

Expected Results:
Only one task is created (in the selected calendar) and shown.

Additional Information:
The task created does not show up in existing ics calendar. Creating task in ics calendar results in one task as expected.

WORKS in Sunbird/0.3a2+ (2006-09-04-07)
FAILS in Sunbird/0.3a2+ (2006-09-04-20)
Probably from bug 349796.  Missing some extra parens?
This adds outer parens to each half of the query, as jminta suggested.

It fixes the duplicates (or more) for me
Assignee: nobody → mattwillis
Status: NEW → ASSIGNED
Attachment #237007 - Flags: second-review?(jminta)
Attachment #237007 - Flags: first-review?(ssitter)
OS: Windows 2000 → All
Hardware: PC → All
Comment on attachment 237007 [details] [diff] [review]
rev0 - Adds more parens

r1=ssitter
Fixes this problem for me too. Maybe Bug 351528 is the same problem? (It's too late now to test it further)
Attachment #237007 - Flags: first-review?(ssitter) → first-review+
Comment on attachment 237007 [details] [diff] [review]
rev0 - Adds more parens

mmm, ambiguous logic...

r2=jminta
Attachment #237007 - Flags: second-review?(jminta) → second-review+
Patch checked in on MOZILLA_1_8_BRANCH and trunk.

-> FIXED

We'll see if this takes care of bug 351528 also.
Status: ASSIGNED → RESOLVED
Closed: 13 years ago
Resolution: --- → FIXED
(In reply to comment #5)
> We'll see if this takes care of bug 351528 also.
> 
I'd be very surprised if it did.  (I'd probably consider it a bug if it did.)  That bug is caused by a lack of || .entryDate when defining ad/bd.
*** Bug 351676 has been marked as a duplicate of this bug. ***
Verified with Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/20060907 Calendar/0.3a2+
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.