Firefox eats memory after closing tabs

RESOLVED INCOMPLETE

Status

()

Firefox
General
--
minor
RESOLVED INCOMPLETE
12 years ago
7 years ago

People

(Reporter: Boris Toloknov, Unassigned)

Tracking

3.6 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [needs leak test results])

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.6) Gecko/20060728 Firefox/1.5.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.6) Gecko/20060728 Firefox/1.5.0.6

Consuequent opening of and closing of the same USR in many tabs leads to lost memory. 

Reproducible: Always

Steps to Reproduce:
1.Start firefox ( 1.5.0.6 ) in safe mode.
2.Open any web page ( the heavier the better, I used http://www.cnn.com ) in about 20-40 tabs.
3.Close all the tabs except the only one and go to the empty ( home ) page in that tab.
4. Watch free memory. Repeat steps 2-3 several times. Every cycle adds lost memory. I used Windows Task Manager and my own tool to watch free memory.
After closing all tabs about:cache says that firefox use no cache ( almost ).
Actual Results:  
Firefox eats a lot of memory ( >100MB ) even though all tabs are closed.

Expected Results:  
Most of that memory must be free.

Comment 1

12 years ago
Can you test this in Firefox 2 beta 2? There have been a lot of memory leak fixes since Firefox 1.5 was released.
Keywords: mlk
(Reporter)

Comment 2

12 years ago
I have tested that with 2.0b2. All the same or even worse.
(Reporter)

Comment 3

12 years ago
Even opening and closing the empty tabs leads to lost memory. After several hundreds opening/closing of empty tabs Firefox ( 2.0b2 in safe mode ) eats > 50MB instead of 30MB when it was started.

Comment 4

11 years ago
Empty tabs - Bug 39238?
(Reporter)

Comment 5

11 years ago
I'm not sure that this bug and 39238 are the same. I see leaks for any new tabs while 39238 says only about "about:blank". I didn't notice any slowdown. The heavier the page the more memory leaks.

Comment 6

11 years ago
See bug 320915; comment 28 of that has details on tracking down leaks.

Comment 7

9 years ago
I am getting this as well
Looks like the memory is not being released.
My Mem Usage, per taskmgr is 87-89,000 K

Comment 8

9 years ago
Can you reproduce using:
* latest version of all plugins (flash, etc), java (1.6_0_13)
startetd in safe mode
 https://support.mozilla.com/en-US/kb/Safe+Mode
with beta
 http://www.mozilla.com/en-US/firefox/all-beta.html
Keywords: mlk
Whiteboard: closeme 2009-07-13
No reply, INCO. Reporter, please reopen this bug if you can see this issue with Firefox 3.5 or later in Firefox Safe Mode (http://support.mozilla.com/kb/Safe+Mode) or a new profile (http://support.mozilla.com/kb/Profiles)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INCOMPLETE

Comment 10

8 years ago
I can reproduce this with the latest version of all plugins, in safe mode.  I created a bookmark to CNN.com, opened it into 20 tabs, then closed all but one, checked memory usage, rinse, repeat.  Memory use continued to go up after each cycle.
Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: INCOMPLETE → ---

Comment 11

7 years ago
Needs leak monitor results (still), etc.
Severity: normal → minor
Status: REOPENED → UNCONFIRMED
Ever confirmed: false
Whiteboard: closeme 2009-07-13
mmortal, can you please provide leak monitor results? thank you.
Version: unspecified → 3.6 Branch

Updated

7 years ago
Whiteboard: [closeme 2010-11-25][needs leak test results]

Comment 13

7 years ago
incomplete without more information
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago7 years ago
Resolution: --- → INCOMPLETE
Whiteboard: [closeme 2010-11-25][needs leak test results] → [needs leak test results]
You need to log in before you can comment on or make changes to this bug.