should we add a "remember my tabs" to the close confirm prompt on quit?

RESOLVED DUPLICATE of bug 383760

Status

()

--
enhancement
RESOLVED DUPLICATE of bug 383760
12 years ago
11 years ago

People

(Reporter: moco, Unassigned)

Tracking

2.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

should we add a "remember my tabs" to the close confirm prompt on quit?

on quit, we march through all the windows and, if your prefs are set right, we'll prompt and warn the user that we are about to close a window with <n> tabs.  

in this scenario, the choice is:  "close tabs" or "cancel".  (This is good, for when closing the window).

but on Quit, what about a third option:  "close and remember tabs"?

or maybe another way to ask for this feature is:  how can I quit the browser and have it remember my windows and tabs (using session restore)?

Comment 1

12 years ago
(In reply to comment #0)
> or maybe another way to ask for this feature is:  how can I quit the browser
> and have it remember my windows and tabs (using session restore)?

You mean apart from setting Tools -> Options -> Main -> When Firefox starts: "Show my windows and tabs from last time"?

All the button would have to do is set the pref browser.sessionstore.resume_session_once to true. And remember not to show that button when browser.startup.page == 3 (the session will then be resumed anyway).
Too bad for people who have set browser.tabs.warnOnClose to false :).
Hey Simon,

> You mean apart from setting Tools -> Options -> Main -> When Firefox starts:
>"Show my windows and tabs from last time"?

I'll try it and see how that works.  (I wonder if it plays nice with the browser.tabs.warnOnClose pref?)

Alternatively, a "File | Exit (but remember windows / tabs")

Maybe this isn't a great RFE idea, but a decent extension idea.
>> You mean apart from setting Tools -> Options -> Main -> When Firefox starts:
>>"Show my windows and tabs from last time"?
>
>I'll try it and see how that works.  (I wonder if it plays nice with the
>browser.tabs.warnOnClose pref?)

That's pretty cool!  

I guess I was after something that would do that, but on a case by case basis.  (File | "Exit and show these windows and tabs the next time I start")
I actually think I saw an extension like this. Or did I? Hmm.

Updated

11 years ago
Duplicate of this bug: 381068

Comment 7

11 years ago
(In reply to comment #5)
> I actually think I saw an extension like this. Or did I? Hmm.

Additional entry in the File menu:
Save Session - https://addons.mozilla.org/firefox/4199

Additional button to the "Confirm close" prompt:
Session Fix - https://addons.mozilla.org/firefox/4542

The second one would be nice to have for Firefox itself (for IE7 parity).

Updated

11 years ago
Duplicate of this bug: 381641

Comment 9

11 years ago
Duping to bug 383760, since it has a patch, been fixed, etc.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 383760
You need to log in before you can comment on or make changes to this bug.