Closed Bug 351781 Opened 13 years ago Closed 13 years ago

Sunbird startup error / views not displayed

Categories

(Calendar :: Sunbird Only, defect, critical)

defect
Not set
critical

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: ssitter, Assigned: mattwillis)

References

()

Details

(Keywords: regression)

Attachments

(1 file)

Sunbird startup error / calendar views not displayed

Starting Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060907 Calendar/0.3a2+ Build-Id 2006090723 causes:

Error: [Exception... "'Error opening input stream (invalid filename?)' when calling method: [nsIModule::getClassObject]"  nsresult: "0x8057001e (NS_ERROR_XPC_JS_THREW_STRING)"  location: "JS frame :: file:///D:/sunbird/js/calUtils.js :: getCalendarManager :: line 65"  data: no]
Source File: file:///D:/sunbird/js/calUtils.js Line: 65

Error: [Exception... "ServiceManager::GetService returned failure code:"  nsresult: "0x80570016 (NS_ERROR_XPC_GS_RETURNED_FAILURE)"  location: "JS frame :: file:///D:/sunbird/js/calUtils.js :: getCalendarManager :: line 65"  data: no]
Source File: file:///D:/sunbird/js/calUtils.js Line: 65

Error: uncaught exception: [Exception... "ServiceManager::GetService returned failure code:"  nsresult: "0x80570016 (NS_ERROR_XPC_GS_RETURNED_FAILURE)"  location: "JS frame :: file:///D:/sunbird/js/calUtils.js :: getCalendarManager :: line 65"  data: no]


Maybe again the problem that new added files are not packaged because not listed in m/c/installer/windows/packages-static?
We forgot to add calItipItem.js to packages-static in bug 350965.
This patch adds it.
Assignee: nobody → mattwillis
Status: NEW → ASSIGNED
Attachment #237323 - Flags: first-review?(jminta)
Comment on attachment 237323 [details] [diff] [review]
adds calItipItem.js to packages-static

r1/r2=jminta
Attachment #237323 - Flags: second-review+
Attachment #237323 - Flags: first-review?(jminta)
Attachment #237323 - Flags: first-review+
Severity: normal → critical
OS: Windows XP → All
Hardware: PC → All
Patch checked in on MOZILLA_1_8_BRANCH and trunk.

-> FIXED

ssitter: Thanks for finding this so quickly! It saved us having to respin, or at worst, a lost day of testing!
Status: ASSIGNED → RESOLVED
Closed: 13 years ago
Keywords: regression
Resolution: --- → FIXED
Verify fixed with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/2006090806 Calendar/0.3a2+
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.