Closed Bug 351868 Opened 14 years ago Closed 13 years ago

Error when changing start/end time of event with drag&drop

Categories

(Calendar :: Calendar Views, defect)

x86
All
defect
Not set

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: damian.publicemail, Assigned: ssitter)

References

Details

Attachments

(2 files)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; pl; rv:1.8.0.6) Gecko/20060728 Firefox/1.5.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060908 Calendar/0.3a2+

when I try to change start date of event via drag&drop I get error

Reproducible: Always

Steps to Reproduce:
1. move mouse over top border of event
2. click (to change start date)
Actual Results:  
Error: missing ) in parenthetical
Source File: chrome://calendar/content/calendar-multiday-view.xml
Line: 233, Column: 75
Source Code:
            [event.ctrlKey ? (this.mOccurrence.parentItem, this.mOccurrence]));


works for previous build so this is probably regression of bug 321384
Confirmed using Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060908 Calendar/0.3a2+
OS: Windows XP → All
Summary: error when drag&drop event → Error when changing start/end time of event with drag&drop
Fixes line per discussion with dmose in IRC
Assignee: nobody → mattwillis
Status: NEW → ASSIGNED
Attachment #237384 - Flags: second-review?(dmose)
Attachment #237384 - Flags: first-review?(ssitter)
Comment on attachment 237384 [details] [diff] [review]
fixes typo (checked in)

r1/r2=dmose via IRC
Attachment #237384 - Flags: second-review?(dmose)
Attachment #237384 - Flags: second-review+
Attachment #237384 - Flags: first-review?(ssitter)
Attachment #237384 - Flags: first-review+
Comment on attachment 237384 [details] [diff] [review]
fixes typo (checked in)

r1/r2=dmose via IRC
Attachment #237384 - Attachment description: fixes typo → fixes typo (checked in)
After that line fixed I get the following error:
 Error: aItem has no properties
 Source File: chrome://calendar/content/calendar-multiday-view.xml Line: 2481
Assignee: mattwillis → nobody
Status: ASSIGNED → NEW
*** Bug 352018 has been marked as a duplicate of this bug. ***
This was changed from evbox.mOccurrence to this.mOccurrence by mistake with Bug 321384. Reverting to correct scope fixes the drag'n'drop issue.
Assignee: nobody → ssitter
Status: NEW → ASSIGNED
Attachment #237601 - Flags: second-review?(mvl)
Attachment #237601 - Flags: first-review?(mattwillis)
Comment on attachment 237601 [details] [diff] [review]
use correct scope

r1=lilmatt

Sorry. :(
Attachment #237601 - Flags: first-review?(mattwillis) → first-review+
Flags: blocking0.3+
Comment on attachment 237601 [details] [diff] [review]
use correct scope

In the interest of us having more usable builds in the morning, I'm gonna steal the second-review of this.  r2=dmose
Attachment #237601 - Flags: second-review?(mvl) → second-review+
Whiteboard: [needs checkin]
Patch checked in on MOZILLA_1_8_BRANCH and trunk

-> FIXED
Status: ASSIGNED → RESOLVED
Closed: 13 years ago
Resolution: --- → FIXED
Whiteboard: [needs checkin]
verified with
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060917 Calendar/0.3a2+
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.