Text cursor doesnt blink after pressing enter to go to the new line.

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
12 years ago
10 years ago

People

(Reporter: aeroman10, Unassigned)

Tracking

2.0 Branch
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: CLOSEME 07/14, URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.0.6) Gecko/20060728 Firefox/1.5.0.6
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.0.6) Gecko/20060728 Firefox/1.5.0.6

This is a problem between Firefox and Invision Power Board version 2.1.7 (or maybe all 2.x versions). When you are posting a new topic or replying to a topic and press the enter key to go to a new line the text cursor does not blink -- it either shows a . or nothing at all. If you type though the text does go on the correct line but there is just no blinking text cursor to show where you are.

If you press the enter key twice the text cursor is still not visible and it instead places a | symbol between the lines.

So for example you maybe typing a sentence and press enter twice ... it will look like this:

Example sentence ...
|
After pressing enter twice

I tried using Safari and it worked fine. The text cursor blinks where it should even after pressing return to go to the next line. This issue only occurs when using Firefox.

Reproducible: Always

Steps to Reproduce:
1. Go to a website that is using an up to date version of Invision Power Board such as http://forums.pcpitstop.com or http://www.houstonsportstalk.com
2. Post a new topic or reply to existing topic.
3. Type something on the first line and press return/enter once to see that the cursor is not blinking on the next line -- press return twice to see that firefox places a | symbol in between the lines and the cursor is still not visible.



Expected Results:  
The text cursor should blink on the new line after pressing return.

Comment 1

12 years ago
Firefox 1.5.0.6 and 2.0b2 on Intel MacOSX: the cursor works fine except it
isn't blinking, i.e. I see a solid |

Latest Minefield trunk build: the cursor is blinking and works fine.
(I only tested http://forums.pcpitstop.com though)

Steve, could you test a nightly trunk build just to see if it works
for you too? Thanks.
http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-trunk/
(Reporter)

Comment 2

12 years ago
I just tried the 1.5.0.7 build -- Same problem.
When going to new line you dont see the cursor. When pressing enter again you jusst see |

I havent tried the latest nightly trunk build - didnt really want to install a test build on this computer.
(Reporter)

Comment 3

12 years ago
I upgraded to Firefox 2.0 (Mac)
Having the same problem with the cursor again.
Can anyone confirm this?
Reporter, do you still see this problem with the latest Firefox 2? If not, can you please close this bug as WORKSFORME. Thanks!
Whiteboard: CLOSEME 07/14
Version: unspecified → 2.0 Branch

Comment 5

10 years ago
Works for me, Firefox 3.0 on Linux and MacOSX 10.5.3.

Please reopen the bug report if the problem still occurs in Firefox 3.

-> WORKSFORME
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.