Closed Bug 352052 Opened 15 years ago Closed 11 years ago

Add XUL mode to DOMParser

Categories

(Core :: DOM: Core & HTML, defect)

x86
Windows XP
defect
Not set
normal

Tracking

()

RESOLVED WONTFIX

People

(Reporter: account, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8.0.6) Gecko/20060728 Firefox/1.5.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8.0.6) Gecko/20060728 Firefox/1.5.0.6

If a XUL document is parsed with DOMParser, it is has to be treated as XML. The XUL parser in FF parses XUL documents as non-XML. The result is a DOM tree that is different because DOMParser creates plenty of whitespace text-nodes which are normally not created by the internal XUL parser.
It would be fine to have a DOMParser that handles application/vnd.mozilla.xul+xml similar to the "internal" XUL parser.




Reproducible: Always
Assignee: general → nobody
QA Contact: ian → general
Technically chrome could could still make use of it. But unless there are actual requests to do so from front-end people I agree we shouldn't do this.

So far I have not heard any such requests, so WONTFIXing for now.

Anyone is free to reopen or file a new bug if they could use this in chrome code.
Status: UNCONFIRMED → RESOLVED
Closed: 11 years ago
Resolution: --- → WONTFIX
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.