Can't select other tabs while importing bookmarks from file

RESOLVED FIXED

Status

()

RESOLVED FIXED
12 years ago
11 years ago

People

(Reporter: zurtex, Unassigned)

Tracking

2.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.8.0.6) Gecko/20060728 Firefox/1.5.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.8.0.6) Gecko/20060728 Firefox/1.5.0.6

When trying to import bookmarks from a file you can use all other browse functions (e.g open tab, close tab, select link, type in a form etc.) except for selecting a new tab.

Reproducible: Always

Steps to Reproduce:
1. Have Firefox open with multiple tabs
2. Select "Bookmarks"
3. Select "Manage Bookmarks..."
4. Select "File"
5. Select "Import..."
6. Select "From File"
7. Select "Next"
8. Click on Firefox Main Windows
9. Try and select a different tab
Actual Results:  
Unable to select a different tab

Expected Results:  
Should be able to select a different tab
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1b2) Gecko/20060909 BonEcho/2.0b2
I'm not sure what you mean with your step 8, but if you mean that I should open a new window and that this window is non-functional in many aspects, this bug is a duplicate of Bug 257121.
(Reporter)

Comment 2

12 years ago
No, I don't think I mean that at all.

After Step 7 a Window Opens named "Import Bookmark file:"

By Step 8 I mean deselecting this window and selecting the firefox window which has multiple tabs open. This windows now no longer has the functionality to select a different tab. Although all other functions appear unaffected.

This is in the same firefox process, Bug 257121 seems to refer specifically to opening a new firefox process. Also the remit of my bug does not cover such things as "Right Click on a link > Save link as", because you can no longer use the same firefox process.

Although I may be mistaken, I tried my best to look for this bug on bugzilla but am not 100% it is not a dupe. 
(Reporter)

Comment 3

12 years ago
By "firefox process" I mean unique window, sorry, this whole bug reporting thing is new to me. I'm still getting a bit used to the technical language.
(In reply to comment #2)

In that case it works for me with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.6) Gecko/20060728 Firefox/1.5.0.6

Please retest with disabled extensions or in Firefox's safe-mode to exclude extension problems. If there are still problems, try creating a new profile. Also a reinstall in a new clean directory could help.

http://kb.mozillazine.org/Safe_Mode_(Firefox)
http://kb.mozillazine.org/Profile_Folder


(Reporter)

Comment 5

12 years ago
Thanks for that.

I was able to replicate the bug both in safe mode and on a completely clean install of Firefox, using exactly the same steps I described. I will try and replicate the bug on different computers later to further confirm this. 
(Reporter)

Comment 6

12 years ago
Right, I have just tried to replicate this bug on my home computer which has a fairly different set up.

Firstly I am running it on Windows Vista Pre-RC1 build (5536)
Secondly I am running Firefox 2 Beta 2

Using exactly the same steps (bar some name changes in the UI) I was able to replicate the bug exactly the same.
(Reporter)

Comment 7

12 years ago
Right I've now tested this on a computer running XP x64 and XP Home, both running Firefox 1.5.0.6 EN-GB.

The bug can be replicated on all of them
Reporter, do you still see this problem with Firefox 2.0? If not, can you please close this bug as WORKSFORME. Thanks!
Version: unspecified → 1.5.0.x Branch
(Reporter)

Comment 9

11 years ago
Yes, I still see the problem with Firefox 2.0, still able to replicate the bug perfectly.

Updated

11 years ago
Version: 1.5.0.x Branch → 2.0 Branch
(Reporter)

Comment 10

11 years ago
Just tried to replicate this on the latest nightly build of Firefox 3 on Windows XP x64 and I wasn't able to replicate the error. Though places did crash on me while trying to do it once, so I'll check again when Beta 1 comes out.
(Reporter)

Comment 11

11 years ago
Places makes this bug obsolete, fixed on latest builds.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.