Edit/Delete in context menu doesn't work [Error: occurrence has no properties]

RESOLVED FIXED

Status

Calendar
Lightning Only
RESOLVED FIXED
12 years ago
11 years ago

People

(Reporter: Stefan Sitter, Assigned: Michael Büttner (no reviews TFN))

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
Edit/Delete in context menu doesn't work.

Steps to Reproduce:
1. Create event
2. Select event
3. Select 'Edit Item'/'Delete Item' from context menu

Actual Results:
Nothing happens. Neither edit dialog is shown nor is the event deletes. Error in console:

Error: occurrence has no properties
Source File: chrome://calendar/content/calendar-item-editing.js  Line: 186

Works in Lightning/0.1+ (2006090706)
Fails in Lightning/0.1+ (2006090806)
(Reporter)

Updated

12 years ago
Flags: blocking0.3?

Comment 1

12 years ago
Confirmed with Lightning 2006091006 in Thunderbird 2.0a

Updated

12 years ago
Flags: blocking0.3? → blocking0.3+
(Assignee)

Comment 2

12 years ago
Created attachment 237963 [details] [diff] [review]
patch v1

obviously a regression from the selection checking. this patch iterates all selected items and calls delete/modify on them. personally, i don't believe this is a perfect solution since it brings up the "all or this occurrence"-dialog for each selected item. but for now, i think it's a reasonable way to handle the situation.
Assignee: nobody → michael.buettner
Status: NEW → ASSIGNED
Attachment #237963 - Flags: second-review?(dmose)
Attachment #237963 - Flags: first-review?(thomas.benisch)

Comment 3

12 years ago
Comment on attachment 237963 [details] [diff] [review]
patch v1

I also think, that this solution is not optimal from a usability
point of view. Especially the 'Edit item' case is difficult, with
this patch the event dialog is opened for each selected event.
But I agree that those issues should be resolved after 0.3 is
released. Otherwise the patch is fine.

r1=tbe
Attachment #237963 - Flags: first-review?(thomas.benisch) → first-review+
(Assignee)

Comment 4

12 years ago
I think we should spin off a follow-up bug which properly addresses the usability related bits and pieces but doesn't block the 0.3 release.

Comment 5

12 years ago
Comment on attachment 237963 [details] [diff] [review]
patch v1

Agreed; less than ideal, but much better than totally broken.  r2=dmose.

I actually believe that we should probably be using some specific affordance to handle editing multiple instances of an event, and the default should always be single occurrences.  But that's another bug...
Attachment #237963 - Flags: second-review?(dmose) → second-review+

Comment 6

12 years ago
I think the spinoff is bug 320178.
OS: Windows 2000 → All
Hardware: PC → All
Whiteboard: [needs checkin]
Patch checked in on MOZILLA_1_8_BRANCH and trunk.

-> FIXED
Status: ASSIGNED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
Whiteboard: [needs checkin]
(Reporter)

Comment 8

12 years ago
*** Bug 352480 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 9

12 years ago
With the current solution it is possible to run into e.g. the following error: 
- select multiple occurrences of the same repeating event
- press Del, Select 'All occurences' in the first popup, select 'This only' in the second -> failure in transaction code.

(Sunbird doesn't handle this at all for the moment, see Bug 332266)

Updated

12 years ago
Whiteboard: [litmus testcase wanted]

Comment 10

11 years ago
Litmus testcase 2692 created
Whiteboard: [litmus testcase wanted]
You need to log in before you can comment on or make changes to this bug.