protocol xmpp isn't associated with any program

RESOLVED INVALID

Status

()

Firefox
File Handling
--
enhancement
RESOLVED INVALID
12 years ago
8 years ago

People

(Reporter: Alexander Sashnov, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.6) Gecko/20060728 Firefox/1.5.0.6 (Debian-1.5.dfsg+1.5.0.6-3)
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.6) Gecko/20060728 Firefox/1.5.0.6 (Debian-1.5.dfsg+1.5.0.6-3)

On the main page of http://bombus.jrudevels.org/ is link:

xmpp://bombus@conference.jabber.ru

When I click on them I get following error message:

Firefox doesn't know how to open this address, because the protocol (xmpp) isn't associated with any program.

How I cat associate xmpp with my IM client, Gaim for example?

Is fix required in firefox, or gaim, or both?

Reproducible: Always

Steps to Reproduce:
1. open main page of bombus.jrudevels.org
2. click to "Конференция" link in right middle place

Actual Results:  
You can see error message from Firefox

Expected Results:  
Gaim or other IM will opens add buddy dialog with selected address to add.

Comment 1

11 years ago
Протокол xmpp вроде как бы уже официально оформлен, но никто не торопиться его поддерживать. А зря

http://www.xmpp.org/rfcs/rfc4622.html

p.s. sorry for my russian.. my english is very bad.

Comment 2

8 years ago
I'm not sure if this is still an issue...I get prompted with the purple-url-handler (from pidgin) with the option to remember my choice.  Is that sufficient from Firefox's perspective?
Severity: minor → enhancement

Comment 3

8 years ago
The program that provides xmpp:// support should register this as a default handler at the operating system level. Firefox reads gnome's default protocol handler. If your chat program does not do this for you or you are not using Gnome then you will need to do it manually by following http://kb.mozillazine.org/Register_protocol#Linux
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.